Kaseya Community

Replicating KES "Upgrade" Button Actions Without the Forced Reboot

  • Hi Guys -

    I've been trying to find a work around for this all week... just submitted a ticket for it...

    We just upgraded to 6.3..

     We need to update all of our servers from AVG 9 to 2012. However, we need to control the mandatory reboot within the “Upgrade” KES GUI button.

    I’ve already written K procedures for UAC and other toggles before and after a fresh KES 2012 install… and I’ve gotten them to work without a reboot.

    This is allowed because Kaseya provides the before and after procedure options on an install…

    However, the KES “Update” button doesn’t give us any configuration options. It just does whatever it's programmed it to do…. Which I assume is an msiexec removal and install with reboots.

    I’ve tried removals and installs manually… but then KES gets out of sync and pulls: FAILED at 11:29:02 6-Mar-13(Unknown failure)

    1. Is there any way that I can edit the commands within the KES “Update” command?
    2. Does anyone know what procedures it’s performing?
    3. Is there any method to simulate a KES upgrade programmatically with K procedures, scripts, batch, or an app – so that KES “sees” the upgrade?

    Thanks in advance

    Other than this... 6.3 is rocking


  • My understanding is that the AVG installer requires the reboot. If you get it upgraded to 2012 from either script or manual install, you should be able to connect client. My understanding is that Connect Client synch's the manual install into Kaseya. It might at least be worth looking at what scripts the Connect calls.

  • Thanks Kunzi..

    Yeah I'm using the "Connect Client" cmd to purge the endpoint's install status for a second and allow me to run another "Install" command with pre and post procedures on it.

    I'd still like to know what it's doing behind the scenes. Do you know where the script is located? I spent an hour looking for it..

  • You used to be able to manually pull up scripts that were run by holding alt and clicking to the right of the procedure (In procedure history on live connect), but unfortunately thats been disabled. I believe they changed a lot of scripting to me more dynamic. On my machine it looks like the connect ran a registry check, then called script 5371994 for KES Reconnect Endpoint/lf_1.A (most likely changes), and then KES Reconnect Endpoint 1245.

    The change on the script visibility was one of the changes made in 6.3 unfortunately.

  • I was trying to use the legacy Alt Click trick the other day, and found that it no longer worked. Rats, that used to be a cool way to get a sense of what was happening in a script.  I can't recall the last time I tried to use it, but I think it was prior to our 6.3 upgrade.