Kaseya Community

AVG 2012 KES Issues since Security Center Fix now there are Install Issues

  • Since AVG 2012.0.2238 271.1.1/5572 now it does show up in security center.  Now there are other issues, since the fix with security center now it does not pay any attention to the options selected for install, instead it installs all options for AVG (Email Scanner, Link Scanner, Web Shield, Firewall) even though I have only Resident Sheild & identity protection selected and none of the others.  Any agents that were installed before Security Center fix now show up in Security Center and seem to work normal.  The issue now is any that are upgraded from 9 or a fresh install after this fix which is AVG 2012.0.2238 271.1.1.  The worst part is AVG Firewall blocks kaseya agents from talking to the server so they go offline once the new 2012 is installed either fresh or you update version 9(AVG 2012 Firewall Issue which block agentmonitor port 580).  The only way we have gotten agents back online was to remote desktop to the computer from another pc on the same network and disable the AVG firwall.  Any 2012 installs previous to security center fix update fine and now work with security center.   This all happened since the Security Center release/fix which did work but unfortunately it broke other critical components.   Before the security Center release the install options worked, only issue seemed to be Security Center not seeing AVG installed. Ticket CS143751: “AVG blocking kaseya agent from talking to kserver plus installing all options instead of looking to selected install options.”   We submitted a ticket last week and support requested we reset their password in our kserver and send it to them which we did so they could check it out further.  Still no updates from support so finally called yesterday to see where they were at, they had no update but said they would reach out to us soon, still yet to hear a response.  Will keep all posted but would love to hear if any others are seeing this issue with new installs/upgrades to 2012 since the Security Center fix release.   Graig Hart also mentioned he is having the same issues with new installs.

  • Hi James,

    I have seen three entries from you in the community to this problem. I can't help you directly. But what you can to is send an E-mail to amado.hidalgo@kaseya.com . This is a really good man at Kaseya and I think he can help you to get the right information and help.


  • Thanks Richard,

    I will send an email out to him with our case number.  The reason I opened this last post was in case anyone other than us and Greg Hart have had this issue without them having to dig through those old posts.  Thanks for the information hopefully this will help us get a resolution.

  • It would be super if somone from Kaseya could let us know if this is a confirmed known issue?  Or are the problems reported isolated to specific users?

    I am holding off on upgrading to KES 2.3 and to Kaseya 6.3 until I am feel confident we will nto experience this issue.



  • upgrading to KES 2.3 was a big mistake and by staying away from upgrading to 6.3 am not repeating another mistake. Please remember BUDR is history when you move to 6.3 and I love stay with BUDR else looking for alternates not those offered by Kaseya.

  • Where you able to get this fixed??

    I also have this problem.  For some reason after upgrading about 20 PCs from aVG 9 to AVG 2012 in KES, some of them "not all" installed EVERY module including the Firewall.  Well after the reboot the agents never checked back in, unless i disable firewall in AVG.  Have a ticket with Kaseya but I think this is going to be a prolonged issue.  

  • Chimoe: I have the same problem with the 6.3 preview server.  I have a ticket open with Kaseya.  Please post if you get any updates.

    It is frustrating that I am not able to update and support my customers that are using Windows 8.  The fact that Kaseya 6.3 requires KES 2.3 makes matters worse since I cannot even update the core functions of Kaseya without fear of introducing major problems with KES.

    Rajeev: Are you sure BUDR goes away with version 6.3?  I know there has been discussion about updated versions of Acronis, but in the BUDR forum, it looks like folks that updated to 6.3 are still able to use BUDR.

  • I have a case open with support on this issue.  They asked for computer that had the issue and said they were taking logs and sending them to AVG last Friday.  Havent heard anything yet but will be trying to get a status update today.  Will keep all posted if and when it gets corrected.

  • I have posted an update about this in the primary AVG 2012 thread.  Can anyone from Kaseya comment on this issue?  How widespread is it?  Has any progress been made in correcting it?

  • @eperson: I think after moving to 6.3 we can't buy any more budr license, but yes can only use the left over license. But recently heard a rumor that at back end Kaseya is rebuilding relations with Acronis and might come up with another release of BUDR. I wish this rumour come true.

  • All,

    I posted this message in the AVG 2012 thread, but I am going to re-post here, and lets follow the "Installing Extra Components" and "firewall blocking" issues reported after the Security Center fix here…

    Based on the reported problems, we are holding off on installing the KES 2.3 upgrade, which in turn is blocking our upgrade to Kaseya v6.3.

    How about this.... could everyone who is experiencing the problem on additional AVG components being installed (such as firewall) and then having communication with the K Server subsequently blocked (by the firewall, I believe), please post the following information to this thread:

    1) your K Server version (i.e. Kaseya v6.2, or Kaseya v6.2, or otherwise)

    2) your KES version (I am assuming this would be KES v2.3 for everyone)

    3) your support ticket number with Kaseya

    4) the date you opened your support ticket with Kaseya

    5) the current status of your support ticket with Kaseya( i.e. what's the latest thign you heard, what are they doing next, etc)

    I think this information would help everyone in the community - so that everyone in the KES community might be able to know more how many people are having the problem, which versions of KES and Kaseya they are running, the current status, etc.

    Thanks very much.



    To help get things started, here is a copy & paste of some related posts from the AVG2012 thread….


    Posted by James M Sherman

    on2-14-2013 9:35 AM

    I have a case open with support on this issue, installing unselected modules but we are on 6.3.  They asked for computers that had the issue and said they were taking logs and sending them to AVG last Friday.  Havent heard anything yet but will be trying to get a status update today.  Will keep all posted if and when it gets corrected.


    Posted by Elliot Tabush

    on2-7-2013 1:41 PM

    I did a KES install this morning and it only installed the components i selected (none). I'm still on 6.2 so not sure if that makes a difference


    Posted by eperson

    on2-15-2013 3:08 PM

    I have opened ticket CS146171 in regards to the install from the SAAS preview server installing unwanted components on Wednesday.  I got a response on Wednesday stating from Arjun at Kaseya support stating "We believe that this has been hot-fixed and is no longer the case. " I then recreated the issue several times and provided example machines.

    I asked if there was any update on Thursday and did not receive a response.

    I asked for an update again today and asked if someone could cal me to discuss.  I haven't gotten a response yet.

    I hope this issue can be resolved soon. Alternatively, if someone has Kaseya could assure me I won't have this problem when I update my production server, I would very much appreciate it.


    Posted by Craig Hart

    on2-14-2013 7:54 PM

    Lloyd and others.

    I've run KES 6.3 on K 6.2 and 6.3 (my own on-premises server). I've not experienced ANY problems with profiles not working, firewalls blocking or anything else like that. I had an issue I initially mistook for a firewall problem, but it was simply the client turning off his machine during a KES install. False alarm.

    As far as I can see in this thread, there is only ONE person with an issue - jamesm sherman. Looks like an isolated case.

    I see no reason to to recommend KES 6.3 / K 6.3 to everyone.


  • We upgraded to 6.3 and are using KES 2.3.   I have had a ticket open with kaseya since early last week.  Even requested escalation and haven’t got anywhere but the standard "we have sent your ticket to a specialist ".   Do any specialist exist because I never hear from them.

    The upgrade from AVG 9 to the 2012 installed a bunch of unwanted modules on the PCs (not all, but some of them). We upgraded the PCs at different dates so I’m not sure if it has anything to do with after a specific hotfix update or something.  

    The Firewall Module is the biggest concern, considering it blocked the Kaseya Agent from checking in and got to the point where it blocked PCs from connecting to network shares in AD.  We disabled the Firewall on the offending PCs but the module shouldn't be installed in the 1st place.  Also it's easy for a user to click the "Fix now" button and it will re-enable Firewall.  

    This upgrade to 6.3 has been a real problem for us. We have other issues lingering that are still waiting to be worked on by Kaseya.  

  • Hey Guys I am on version kserver 6.3 & KES 2.3 and I originally opened this post.  Currently I am awaiting an update from kaseya as I spoke with Maurice from development last Friday the 8th and the last thing that was requested by Maurice was a list of computers which were affected by this issue so he could send the logs to AVG for further research.  I  updated our ticket with about 10 - 12 affected machines plus 2 more that were perfect and installed just what we selected which were pushed just before the security fix; they were pushed during the security center issue where windows didn't report any antivirus installed with AVG 2012 so we could see when the security center fix came through.  Those 2  are still fine and updating without issue; still just affects any we upgrade from AVG 9 or install fresh which in reality is the same thing as far as 2012 is concerned.  We still have not received an update and will be calling kaseya tomorrow to see if we can get any updated status.  Our Ticket CS143751 concerning this issue was opened on 2/1/2013 at 9:17 am.  I have also had some luck reaching out to a kaseya contact through email having him ask the development team reach out to me so feel free to try it; amado.hidalgo@kaseya.com .  Just send him your ticket# and maybe he can help get them to call you, worked for us.  I am also sending an email out to our rep and the regional rep to see if they can assist in getting us an update no matter what it may be.  Of course I will keep all posted if we here anything and I will look for any information from you guys.  I think the worst part isn't that they don't have a fix yet it is that they wait so long to give us an update, even if every couple days or weekly they would update our ticket with where they are at would be great!!!  Nothing worse than having our clients ask us about this issue and not being able to give them any timeframe or status on when this will be fixed or if anyone is really working on a solution.  Just hoping they are for our sake:)

  • Hey Guys,

    I received an update from kaseya this morning stating that AVG found the issue with installing all options since security fix by reveiwing our logs.  It seems that when you use company name in your install options that it is missing a quotation in the script when pushed and because of that all selections after that are ignored and that is why everything is installed.  Here is exact response from kaseya:(The issue is caused by missing quotation mark in the CompanyName parameter, In the log is this: /CompanyName="Jiminy Peak, which means that all following parameters are ignored.) Notice after company name there is no quotation.  This is also why this is only affecting some of us as if you dont use the company name option this wouldnt affect your install.  I did do a push this morning to test without company name selected in my install and it installed perfectly only installing the options I selected.  So for now this is a workaround, dont select company name in install options and all should install just as selected.  I will keep all posted when I hear more on when the fix will be released.

  • @ James

    Thanks for shareing this information!