Kaseya Community

Announcement on VSA release ( patch (On-Premise only)

  • The January VSA release ( has been delayed for on-premise VSA customers, after reports of issues with agents not checking in after the update. We are currently testing a fix for both SaaS and on-premise, and will send another communication once we have a new date set for availability of the release. Once the fix has been validated, existing SaaS instances will receive the fix during their regularly scheduled maintenance window, and the installer will be made available for on-premise customers. 

  • Hey Guys,

    I wanted to provide an update.  The previously scheduled January VSA release ( will be combined with the February VSA release and together, they will be referenced as This new release will contain all of the enhancements and fixes that were previously set to be included within each of the respective releases, and will also contain fixes for the issues identified with, namely: 1) Agents not checking in, and 2) Windows OS version misrepresentation. In addition, a separate fix may be made available for the OS version inaccuracy, as soon as possible. The target dates for release are: Feb 27 (On-premise), and March 2 (SaaS).

  • This really sucks.  We were told by support we should expect something today or tomorrow.  We have a bunch of scripts and monitors that DON'T work because of the OS version inaccuracy

  • We escaped this issue, but I can only agree. Screwing this up and postponing a fix that is available (otherwise it couldn't be planned for release next week) is a bad call. If ever there was a time for an emergency fix, this must be it. Breaking one of the main pillars of Kaseya is a big deal and something testing should have caught.

  • You can't install or monitor webroot via tge webroot VSA module for affected agents either. This is really a major headache for many reasons.

  • I understand cloud backup is also affected. The damage is extensive.

  • We have to agree. We pay thousands of dollars of maintenance and the patch that you released are did not even tested before. Many Kaseya customers already told you: please focus your efforts on BUGFIXES before new feature release. Many known bugs on Kaseya are still not patched.

  •  - Have you tried disabling the Webroot API and attempting to install via the Webroot VSA module?  We used that as a workaround for another issue two days ago at the direction of a Webroot tech.

  • Hi we'd installed the original in the brief window in which it was available on-premises.  We aren't really experiencing any problems (at least we haven't noticed) but I just want to make sure when the "new" .18 comes out, we will be able to apply it to our existing version without any issue.. correct?

  • The new .18 will be .19, there will be no rerelease of .18, so im told. So just go ahead and apply .19 normally when it comes out. March 3 I believe.

  • When I opened Helpdesk yesterday I'm sure it said .19 will be coming next week for on-premise and will be installed on SaaS in early March... The message is no longer there and I have no idea where to find it.

    Ah, Oscar also posted it in this topic: Feb 27 for on-premise, March 2 for SaaS

  • Could someone in Kaseya please give us a heads-up around the fix?  Does the fix mean we have to manually connect to each "dead-in-the-water" server and remove and reinstall the agent?  

  • Any special instructions will be included in the release notes.  To my knowledge and having viewed the notes on the fix, there are no manual or special instructions.

  • So Feb 27th come and gone.  No update on here.  No update on my support ticket.

    Some days I just feel like a fool for staying with Kaseya.  

  • Hey Guys,

    Just an update: