Kaseya Community Patch Release - 30 January 2019

  • Hey Guys,

    Kaseya VSA patch has been released.  You can review the latest notes here. Patch Release - 30 January 2019

    The VSA release includes features and bug fixes. See the topics below for details.

    Note: This release requires agent version Be sure to update your Windows, Mac, and Linux agents after installing this release.



    • Created a REST API endpoint to return all available custom fields for a tenant. (VSA-3735)

    Software Management Module

    • The module now checks for attempts to update Unapplied Patch approvals from other tenant admins and, if found, logs details to help determine how these attempts are happening. (VSA-4423)

    Traverse Integration Module

    • Added a new page in VSA that displays all of the events that occurred on the Traverse system for a selected organization. The new page adds the ability to acknowledge, annotate, and suppress individual events. The new page also displays individual event detail and history. (VSA-3551)
    • Added new functionality to the Traverse Data Collector page which displays information about the selected organization and probe. An additional tab was added to display the status of the DGEx deployment/removal agent procedures. Added a button to quickly navigate the Network Monitoring (KNM) page to allow for adding/editing of credentials. (VSA-3910)

    Bug Fixes

    Agent - OS X

    • Fixed an issue that prevented sending messages to Macs via VSA > Remote Control Module > Send Message and/or > Chat. (VSA-4039)

    Agent - Windows

    • VSA now verifies that the agentGUID passed to KServer does not exist before creating a new account. This fix requires an agent update. (VSA-312)
    • The agent installer now contains an informational message in the setup log if there is a failure due to another program currently running that has a volatile registry key. (VSA-864)

    Antivirus Module

    • Fixed an issue which caused KAV\KAM profiles with large numbers of exclusions to fail when assigned to an endpoint. Now, instead of sending the profile settings through endpoint SDK (which has a maximum character limit), the endpoint script gets the profile configurations directly by calling a new REST endpoint. (VSA-343)

    Cloud Backup Module

    • Fixed a password reset issue by updating the parameters passed to Acronis. (VSA-3889)

    Database & Schema

    • Script Log advanced cleanup – Fixed an issue where the nightly removal of sub-steps from the event log could terminate without completing. (VSA-2393)


    • Fixed an issue where endpoint packages were not being deleted successfully. (VSA-4041)


    • Fixed an issue where installs failed after upgrading to due to a missing table in the VSA database. (VSA-4447)

    Live Connect & Remote Control

    • A warning now displays in the LiveConnect event viewer module when no text has been returned. (VSA-4417)
    • Fixed an issue where Remote Control users could not login to Macs after they had logged out or rebooted. The login screen would display, but users could not enter text. (VSA-3036)
    • Fixed an issue where Remote Control would occasionally disconnect the session to a Mac agent when the Mac was locked or the active user was switched. (VSA-4042)

    Patch Management Module

    • Fixed a performance problem in Patch Management that could result in the machine update page failing to render. (VSA-3080)

    Software Management Module

    • Fixed a spelling error in the blackout window. (VSA-4196)

    VSA Core

    • Modified dlMaint.aspx to be accessible only locally to the VSA. (VSA-560)
  •  - This morning the recently renewed Helpdesk page reported was out, but when I clicked the link (help.kaseya.com/.../RN) for the Release Notes it stops at .17. This time I clicked your forum post link and that (help.kaseya.com/.../RN) does work because it links directly to the Release Notes for patch .18. Someone needs to update the list of patches in the first link.

    And another thing I already noticed before. When I open the Community Forum and login I end up at Browse Forums. After sorting on Last Post your Forum post on patch .18 isn't visible. Only when you open the Discussion Forums at the top of the page you see this recent post. Is there a good reason for this, or is it a lack of indexing? When I check the Patch Release forum in the list of all forums it still shows the previous post from the 14th as the last post... I noticed this before, but since it impacts how you use the forum it's good to give it some attention...

  •  the index does need to be updated.  Great catch.

    As for the system patch posts specifically, that is a permission update which needs to be validated.

  • Okay  - It's almost correct, after opening help.kaseya.com/.../RN the left list of the Release Notes with R95 Patch Releases is now showing patch .18, the main window on the right still only shows up to patch .17.

    I'm not sure what you mean by the second sentence. To me it's not working correctly if you can see recent posts by choosing Discussion Forums, but can't see them if you list all forums sorted by last update. I wasn't really aware of the difference, but consider it an issue.

  • patch now identifies The Windows Server 2008R2 OS as "<2003" which causes many scripts to fail.

  • Hi All, This patch is causing some big issues and I would caution anyone from installing it tell Kaseya has found a fix. I have an open ticket with them now on it. The issue is that if you have an older server OS like 2012, 2011, and 2008 after the update the server may then Identify its operating system as <2003 and then procedures will no longer run on them, this also makes it so that Acronis Backups no longer run (Big Issue!) also you can not install, remove or verify the install of Acronis.

    Can you verify this and update us.

  • I'm not seeing this issue on my demo vsa which I updated last week but I only have one 2008R2 agent there. Did you guys ran reapply schema manually after the patch?

    I was gonna update our production vsa today but I think I'll wait for Kaseya's official response.

  • Yes, I ran reapply schema and this did not fix the issue. Also this is not affecting all of the 2008 servers  it seems to be random some that I have are working fine. I would not update at this time.

  • I also have the "< 2003" OS issue. We see it on 2008R2 and SBS 2011 machines. (2012 reports properly). Kaseya Support responded that they are aware of the bug in the VSA and are working towards a solution/fix.

  • Hi All, Patch

    Kaseya Support has updated my ticket and has confirmed that it is a bug and that they are working on it.

    Hello Ron,

    Thank you for contacting Kaseya Support, my name is Donald White and I will be the technician assisting you with this ticket.

    I understand the urgency of your case and we are working to find to root cause and remediations for this issue.

    We have identified this as a bug in the software, and have seen other incidents similar to yours.

    I'll keep you updated on this case, and as our engineering team works through this issue.

    Thank you for your patience.

    Best Regards,

    Donald D. White | Customer Support Engineer

    Kaseya Support

  • Patch .18 seems to be pulled at the moment. My VSA isn't reporting this as available anymore.

    I was wondering if Kaseya shouldn't be doing that and this time they actually did. Good to see Kaseya behave responsibly to their customers who haven't already installed this patch...

  • When i search for latest update it just states the latest is even though i am already on, also if i run kinstall on the server it does an upgrade but says the same thing upgrade to, goes through the normal process, when i log in its still ???

  • i think it has been pulled do to a bug

  • We've opened a ticket as this affected ~20 of our clients and their BUDR. Engineering gave me a call to let me know it could be up to 2 weeks to develop a fix and in the meantime to manually set each client up with a backup using the Acronis Console. Not very happy that this is requiring hours of our labor.

  • , Thanks for the update, I know your pain.