Kaseya Community

Unable to connect to server with RDP

  • There is one server that I am unable to connect to using RDP through Kaseya.  Other machines on the same network as the server can RDP to it without any trouble.  When I try to connect via RDP through Kaseya it just sits at "Configuring remote session..." and never goes any further.  Does anyone have any suggestions?

  • I don't have a solution, but I can verify that we also experienced this on one of our customers servers. A windows SBS 2008.

    It stopped working for a couple of weeks. Then one day it suddenly started working again. :S

  • most times when I have this problem, there is some 3rd party firewall or antivirussoftware which blocks the connection. Sometimes becausse of an update for anti-virus, which needs a reboot.

  • I figured it out. The problem was that the following registry key was missing from the server:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\WinStations\RDP-Tcp

    I found this out by looking through the Agent Log when I tried to connect. Kaseya could not determine what the RDP port number was so it gave up.  I exported the key from another server and imported and the problem is solved.