Kaseya Community

Automatic update not running automatically

  • We use patch management and we schedule patch scans and automatic updates on a weekly basis. Patch scans on Wednesday, Automatic update schedule on Sunday.

    The problem is that Automatic Update is not starting the task to install the updates on Sunday.
    When I schedule the Automatic update manually, let's say start in 5 minutes, then the patch task will run and updates are being applied.

    I checked the Kaseya logs in the 'kworking' directory, but the .XML files are not created when the automatic update on Sunday task should be running. When I manually schedule automatic update for let's say now, then I see the XML files being created and the Windows updates are also visible in the kworking directory.

    I already deleted all the automatic update schedules for all the machine groups and created new schedules. I used Patch Status to verify configuration download and install test, all of them show 'Passed'.

    So the strange thing is that Kaseya is not updating any machine when it should run, lets' say Sunday at 1 AM, but when I schedule the task to run in 5 minutes then it's starts and updates are being installed.

    Another thing I don't understand is the schedule.  I scheduled a Automatic Update job for testing, weekly on Friday, run at 02.15:00 PM, when I click Submit the Next Run is showing 5:17:00 PM instead of 02:15:00 PM.
    I would expect that when I choose 02:15 PM it would start around 02:15 PM, not at 05:17 PM, that is 3 hours later than scheduled!

    The schedule is based on the timezone of the agent, so actually it is starting at 02:15 PM, but why would Kaseya show 05:17 PM as next run schedule?

    [edited by: Wolf82 at 5:08 AM (GMT -7) on May 6, 2016]
  • We also experience Automatic update not running on a couple of endpoints....but not every one.  I am interested to hear how you get this resolved.

    On the scheduling, it is just a display issue?  i.e. you are on the east coast and scheduling it for a machine on the west?   ...The two minutes could be differences in clocks between the agent and the VSA server.

  • I'm from The Netherlands and at this moment it's 2.40 PM.

    I checked the preferences under System in Kaseya management portal and there I can choose the time zone offset.

    We are using 'use time zone of the browser logging into the system' and the current Current VSA Browser time is: 2:40:07 pm, so that is correct.

    If we would choose Use time zone of the VSA server then the Current VSA Server time is: 12:40:56 pm, so that's 2 hours earlier than the time in The Netherlands.

  • What version of Kaseya?  Are you on the latest patch?  Lots of scheduling bugs have been squashed since

  • We're on and when I go to schedule Kaseya Windows Update, if I say to run at 3:00am, it gives me some random time, like 10:43am, or 3:20pm. Is this a known issue?

  • @Mike_Judd

    System version

    Patch Level

    The strange this is that it has worked in the past. Around March 18th a colleague left the company and he was the one that started with Kaseya patch management, creating the machine groups, installing agents, configure Automatic updates, etcetera.

    After he left his Kaseya account was removed, and I'm one of the administrators that is trying to solve this problem, but I cannot find out what it is.

  • Are you scheduling through the Patching module or Policy Management?

    It's probably going to be best to open a support ticket.

  • We are using the Patch Management module. I will submit a ticket to Kaseya support because I'm out of options at the moment and patching almost 100 machines by hand is not what we want.

  • ,

    If you check the Config Changes log at about the time the process should have started, is there an entry indicated that auto updates did/did not start?  Anything in the agent procedure log?  

    Also, you mentioned the process works if you schedule for five min from now, but not when configured with your preferred schedule.  Perhaps the agents are offline at the time of execution and "skip if offline" is enabled.  If this is the cause, it should be noted in the Config Changes log.

  • Hi Wolf82, this does sound very familiar and we have some experience with this issue, and we also happen to be based in the Netherlands.

    You supplied the information your previous administrator left your company and you removed his account. That unfortunately means that his tasks, while still visible, will not run, because his account is no longer supplying the needed credentials. This is something we learned the hard way. To fix this you need to schedule his tasks with your credentials and I know Kaseya has some report to help you find what tasks you need to look at.

    Also, in scheduling is behaving a bit erratic. We found that scheduling something in Patch Management it shows a certain time and spread and uses the previously used time and spread information. So, you see one thing but Kaseya uses the other. We went to and this problem seems fixed now. I just tested it and it works as intended. I just tried to schedule a Patch Scan for my notebook and that seems to be ignored, will be testing that some more.

    So, am curious to hear if this issue was solved and am a bit surprised no one from Kaseya picked up on the issue you removed the user that scheduled Patch Management! With Agent Procedures the master user that removes another user inherits his Agent Procedures, making sure these are not lost. A similar mechanism would certainly be helpfull with scheduled tasks and that maybe covered in 9.3. Someone from Kaseya should be able to answer that.....

    Happy Patching!

  • Hi OudjesEric,

    Thank you for the information.

    We found out that recreating the tasks under my account solved the problem, I did that last week.

    We still had the problem that automatic update tasks were scheduled for a specific time but Kaseya showed times that were not even close to what was specified.

    Kaseya support has solved that problem yesterday after I submitted a support ticket a couple of days ago.

    So when I schedule machines for Automatic Update for let's say 8.00 PM, Kaseya now shows  the next run time as 8.00 PM, 8.01 PM, 8.02 PM.

    On May 6th the patch level was, now it's, so I also think that the patch has solved this issue.

  • After this post we also installed and the scheduling issue seems solved for most, but not all machines.

    Yesterday I was testing with a machine that doesn't execute the existing Automatic Update scheduled by an active user. I scheduled it again as Master user, but still the Automatic Update doesn't run. The Procedure History doesn't log the Automatic Update on the scheduled time, but does show a new scheduled task for next week. This is a difficult one to catch, so not sure if we have more of these problems. This could just be a problematic agent, so must look into this. If there is a real issue I'll post an update.

  • Did you check the 'Configuration Changes' agent log as well? I always check the log so I can see if the patch installation scripts have been generated for the amount of updates I approved and at the same it will show that the processing of Automatic Update has started.

  • ,

    I'm sure you've already checked this, but it's worth mentioning in the event others have a similar issue.  Make sure that if  "Skip if offline" option is enabled for the schedule that the agent was actually online at the scheduled time.  As 82 said, the Config Changes log is a great place to check - and if the sched was skipped because the machine was offline, Config Changes log will make note of that.

  • I just noticed that the new patch level is and now the problem has returned regarding the next run time schedule. Machine groups scheduled for let's say Automatic Update at 3 PM show 7:19 PM as next run time. So I've reopened the support ticket with Kaseya Support.