Kaseya Community

K2 - Moving Folders loses contents

  • I came across this bug and Kaseya Support has confirmed they have reproduced it on their test server. So a ticket is open.

    If you try to move an entire folder from the Private File Cabinet to the Shared Cabinet, all agent procedures in the folder dissapear.

    Moving individual procedures does not appear to be an issue.

    This is occurring in IE and Firefox.

    Legacy Forum Name: K2 - Moving Folders loses contents,
    Legacy Posted By Username: smbtechnology
  • smbtechnology
    I came across this bug and Kaseya Support has confirmed they have reproduced it on their test server. So a ticket is open.

    If you try to move an entire folder from the Private File Cabinet to the Shared Cabinet, all agent procedures in the folder dissapear.

    Moving individual procedures does not appear to be an issue.

    This is occurring in IE and Firefox.


    I just tied this and got "The parent node Exchange - Check Integrety Mailbox Store was not found" error... (This script is 2 deep... )

    The folder I moved "Alpha" and it's scripts moved alright, although the subfolder "Exchange server" is now empty....

    When I move them back to where they were before, all scripts are accounted for =\

    Legacy Forum Name: Scripts Forum,
    Legacy Posted By Username: thirteentwenty
  • I get the "parent node for procedure was not found" errors when trying to filter our list of procedures.

    Thanks for the suggestion of moving procedures back. Saved me the hassle of doing a database restore to recover them.

    Perhaps the script import process was not quite perfected when I did my K2 upgrade.

    So far the only response from Support is the acknowledgement of the issue, there was not any offer to help recover lost procedures. Sad

    Legacy Forum Name: Scripts Forum,
    Legacy Posted By Username: smbtechnology
  • smbtechnology
    Thanks for the suggestion of moving procedures back. Saved me the hassle of doing a database restore to recover them.



    Actually thank my 7 year old nephew lol he asked "cant you just put them back" lol then and only then did I go "good idea" lol...

    Kids they say the darnedest things

    Legacy Forum Name: Scripts Forum,
    Legacy Posted By Username: thirteentwenty
  • Does he want to do some helpdesk work?

    Legacy Forum Name: Scripts Forum,
    Legacy Posted By Username: smbtechnology
  • Checked the system log and saw hotfixes for "MoveTreeNode" & "CopyTreeNode" which sounded like it might be related and now folder moves are working.

    Glad to see a glaring bug like that get sorted quickly.

    Legacy Forum Name: Scripts Forum,
    Legacy Posted By Username: smbtechnology
  • Hotfixes have addressed this one.

    I even got a ticket update to that effect from support.

    If I stare a long long time, I think I see a tiny flicker of light at the end of the tunnel.

    Legacy Forum Name: Scripts Forum,
    Legacy Posted By Username: smbtechnology