Kaseya Community

Server 2008 UAC Issue???

  • Hi all,


    I am writing a script to monitor Windows Server Backup (WSB) backups and generate alarms etc where needed.

    As the WSB reporting in near nothing I need to run the following command on the host machine:

    c:\windows\system32\wbadmin.exe get versions>c:\temp\wsbbackup.txt

    I have tried both running this in a local batch file and via the command shell and execute file functions in the kaseya script.

    I am using and extra > when trying it direct from Kaseya.

    Every time I try it I just get a blank file, however when I run it at the command prompt locally or via a scheduled task the command runs ok.

    I have tried the "use credentials" function and the "impersonate function" neither of which worked.

    The server does have UAC enabled by default, could this be the cause?

    Any ideas?

    John

    Legacy Forum Name: Server 2008 UAC Issue???,
    Legacy Posted By Username: jpcurrie
  • BUMP? Anyone - I am having to run the wbadmin part as a scheduled task at the minute and its a rather ungraceful fix?

    Legacy Forum Name: Scripts Forum,
    Legacy Posted By Username: jpcurrie
  • This isnt the actual script but try something like this below. Note the space between >> and c:\...

    use credential
    execute shell command
    c:\windows\system32\wbadmin.exe get versions>> c:\temp\wsbbackup.txt

    Legacy Forum Name: Scripts Forum,
    Legacy Posted By Username: mwolter