Kaseya Community

Why won't Kaseya run a simple xcopy script?

This question is not answered

This has been an ongoing issue that I'm just now revisiting.  Have a simple command to copy some backup files:  xcopy /s /y /d "\\db1.ait.local\rpm11$\" "\\fs1.ait.local\AIT_DB1_ORA_BACKUP"

It runs perfectly fine locally on the server.  Does not run in the command shell within Live Connect:  "Invalid drive specification."  I've tried running it on both the source and destination servers, and tried with and without the 64-bit command shell mode (that has made a difference on other scripts that fail).

What am I doing wrong?  Do UNC paths not work in Kaseya?

Thanks in advance.

All Replies
  • The good news is that Kaseya can run anything via Shell Command just like you can manually.

    UNC paths are definitely supported.

    The only difference is we run our shell commands as the SYSTEM account.

    When you are running your xcopy command manually you're using it with an account that apparently has access to the file share (e.g. domain admin that naturally has access to many network shares setup on other domain member computesr).

    You need to use the 'Impersonate user' step before you run this shell command and use whatever credentials are necessary for accessing the share. In your shell command step, select to 'execute as user' -- it will actually use the credentials you've previously specified with Impersonate User, and not really the currently logged on user.

  • Awesome.  This is very helpful.  I will try this and report back.

  • Also, you can try to run your own interactive command line as the SYSTEM account a few different ways -- for me, using the psexec method works the best:

    verbalprocessor.com/.../running-a-cmd-prompt-as-local-system