Kaseya Community

Adding registry settings - possible bug

  • Today I needed to update registry settings under HKLM\software\WOW6432Node\ApplicationName and I built my procedure using the setRegistryValue() command in a agent procedure. 

    [{"RefId":"411","Type":3,"Depth":0,"Fold":false,"Hide":false,"Error":false,"ErrorMessage":"","ParameterValues":[{"ScriptParameter":0,"Value":"HKEY_LOCAL_MACHINE\\SOFTWARE\\WOW6432Node\\Zoom\\MSI\\DisableUpdate","PasswordParameter":false},{"ScriptParameter":1,"Value":"true","PasswordParameter":false},{"ScriptParameter":2,"Value":"REG_SZ","Select":true,"NumberOnly":false,"VariableDefinition":false,"PasswordParameter":false},{"ScriptParameter":3,"Value":"0","Select":true,"NumberOnly":false,"VariableDefinition":false,"PasswordParameter":false},{"ScriptParameter":4,"Value":"false","Select":true,"NumberOnly":false,"VariableDefinition":false,"PasswordParameter":false}]}]

    running the command will add the settings but in the wrong spot.

    HKLM\software\WOW6432Node\WOW6432Node\ApplicationName\setting

    not

    HKLM\software\WOW6432Node\ApplicationName\setting

    Next I built a reg file with my settings and tested. Double click the file and settings are imported correctly. I then built a cmd file calling reg import filename.reg and when run locally the settings are imported and in the correct location. I then built a new agent procedure copying the files locally and then running them with the executeshellcommand, but had the same results.

    HKLM\software\WOW6432Node\WOW6432Node\ApplicationName\setting

    not

    HKLM\software\WOW6432Node\ApplicationName\setting

    Has anyone run into this issue?

  • Yes ... Run the command as system in 64 bit is how I think we solved the issue ... took forever to figure it out and almost gave up several times

  • Have you tried not specifying the WOW6432Node part of the path? Obviously, the system is adding that when you write. That's standard file and registry reflection of the O/S. We never specify that part of the path, but write to that actual path all the time.