Kaseya Community

Not able to download "Get File" files from the Kaseya server.

  • I'm getting ready to open a ticket, on this but I thought I'd post here to see if anyone else has run across this first.  

    We just updated to 9.1 last night, and I've run into my first major issue with it.  I've got an agentprocedure that uses the "Get File" command to pull a log file back to the server, and we ran it on a machine this morning.  The file shows up when you browse to the machine under the Agent Procedures->File Transfer->Get File section.  However, if you click the link to download the file nothing happens.  I've tried it in both Chrome and Internet Explorer, and it doesn't work in either.  I know that I can get it by browsing the file system directly so that's what I'll do to work around it for now, but I'm wondering if anyone else has run into this.

    Also to note, the issue isn't limited to "new" files that have been transferred using the "Get File" command, I can't download even files that were transferred to the kserver months ago through this method.

  • Ticket # 93178 for anyone who needs to be able to reference a ticket

  • ....And, while I still don't have a response to my helpdesk ticket (not even assigned to a tech yet...), I just happened to look at something else and see that there is a new patch out... which *supposedly* release yesterday, though it wasn't there at 11:00pm CDT last night when I updated our server, which fixes this exact issue.


  • Hey  

    Sorry for not getting to this thread until today, however you are exactly right on this one.

    To clarify, the release of on July 10 caused one of the symptoms you described.

    Patch released late on July 14 corrects the issues identified. (Problems with Getfile, Import Center, SD Attachments)

    Let me know if I can help or clarify any further on this.

    Best Regards,


  • Hi Jonathan,

    I have just loaded this patch and can confirm it fixes the issue.



  • Just ran across this post. Looks like a recent patch for Kaseya 9.4 may have introduced this issue again. I can no longer download files from "Get File" for any agent using any browser. (Version

  • same issue here, running I've had a ticket open for 2 weeks and all Kaseya support says is that it's a known issue and they have no ETA. That seems to be their response for nearly all problems with Kaseya lately

  • This reminds me of something that I've looked into a couple of times, but keep forgetting to ask.   - Does Kaseya maintain a list of "known issues" somewhere along the line?  Coming from the Connectwise world I'm used to being able to go to their known issues list when I run into a problem, and do a quick search to see if what I'm dealing with is already a known issue or not.  Then when opening a ticket I could specifically indicate if what I'm running into is just a "me too" type of ticket about an already known issue just so that they know there is another customer having the issue, and I could also track the "known issue" ticket to determine when a "fix" has been released.

    Provided you can get customers on board with *using* the known issues list, I could see this actually saving a lot of time on the support side of things, in that 1.) a lot of times if what I was running into was already on the known issues list, I wouldn't even bother opening a ticket, I'd simply follow the existing open issue, and 2.) on the few times that I *would* create a new ticket, I could reference the existing known issue and then the assigned support tech didn't have to spend any time researching to see what the problem was, they could simply attach my ticket to the already existing ticket.

  • Aside from, say, Cisco, I think you'll be hard-pressed to find a vendor in a competitive space that will willingly provide a "known issues" list, except perhaps to those in a beta or under NDA.  It's just too much ammunition for competitors to use against the vendor posting the info.  $0.0299