Kaseya Community

Kaseya Agent Deployment on Windows Server 2008

This question has suggested answer(s)

I am looking to deploy Kaseya agents over 25 windows server 2008.  I noticed that with lan watch deployment methods and if you push the agents out remotely you have to reboot the machine (tested it out on windows 7 pcs).  However if you run the installer package (not remotely)  there is no need for a reboot.  Is this the same case for windows server 2008?  I am thinking of using a gpo (but the installer needs to be repacked to a msi) to rollout to these windows server 2008.  Would anyone recommend any other methods?

Thanks in advance.


All Replies
  • You do NOT have to reboot the machines with a Lan Watch deployment.

  • I don't ever recall having to reboot any machines while installing an agent manual, or push, now doing it via group policy thats a different story...

    Please clarify your method of "PUSH".

    The first method I try (because it's the least invasive) is the push,

    First run install on something (preferably the DC) and run a LAN Watch (if you catch it in the middle of the day you can grab workstations too), Make sure you have domain admin credentials and have tested it...

    How to push

    Then go to Agents |>  LAN Discovery > Install agents

    Select the machine you ran the LAN watch on

    Select the machines you want to push to, fill out the needed info and hit install...

  • Thank you both for the fast response.  After more testing here are the steps I took:

    Logged on to a domain controller, installed agent via a link from kaseya server and everything went smoothly.  There was no need to restart.

    Scheduled a LAN watch and discovered all the servers that I need to install on.

    Then I went to LAN Discovery -> View AD computers and selected all servers I needed and pressed install agent policy.  However in the machine ID column it says "install at next reboot"

    So to test this, I logged on to one of the servers and restarted it and the agent was installed fine.

    Here is the issue these are all Win 2008 servers, I do not want to log on to each of them and install this manually however the remote deployment option does not work unless you restart?

  • Yeah, dont se that method lol use the way I described and you'll avoid the reboot...

    What you're doing is creating a GPO for the install on start up... I don't recomend that for servers...

  • And... (I'm to lazy to go through all the hullabulloo to edit) you'll need to log on to the DC and delete the GPO and the associated files...

  • Thank you I will try this and come back with the results.

  • I tried what you suggested from the install agent option. However Kaseya came back with an unknown response message.  I already removed the GPO from the DC and ran through the checklist before running the install agent option.  

    I checked that file and print sharing is on

    Checked that the credentials are correct

    Used the correct user name in form of Domain\username

    Checked that it is the same OS type

    Is there a log where I can find out from kaseya what is going on?  Apart from just a unknown response message?  There are logs on the specific machine after you install it and it will announce if kaseya agent has issues connecting to the server and so forth or if there were other installation issues.

  • Did some further testing and found something very interesting.  With the LAN Discovery install agents option if you use the "enter IP address or name here to attempt install to an undiscoverd machine" and you put in IP address it works perfectly.  However if I don't use that option and use the check boxes to select a number of servers, it comes back with an unknown response reply.  Also if I use the host name of the server in the "enter an IP address or name here to attempt install to an undiscovered machine" it does not work as well.

    So this has to do with DNS?

  • I'm having the same problem as Harbour, Agents |>  LAN Discovery > Install agents use to work perfectly for me.... now I get "unknown response"

    BTW these are all server 2008 R2 servers

    Kaseya :/

  • Having the same issue and cant deploy global due to this. I have opened a support ticket and will feed back what I find out..

  • Don't know if this is of any use or not but one of my techs was doing a take on yesterday and our agent simply wouldn't install on their 2008 SBS box, we tried remote LAN install from a PC dialling into the server via RDP.  We couldn't get anything to work until we removed the /e added the /r /w to the installer and this worked perfectly.  

    This was a completely new customer for us and there was no sign of any previous installation but for some reason the installer was killing itself.

  • Just tried your suggestion.. No joy.. still errors with "unknown response".. all of the things I can think of that may be at the heart of the issue seem to turn into vapor once you bring back the fact that the install works fine if I do it from the "undiscovered machine" section and list its IP. The ones I do their install and are fully functional. Once I head to my production environemnt doing them one IP at a time will just not work out..

  • Go to the server\computer that you have run Lan Watch on. From a command line go to the kaseya install folder that holds the exe kausrtsk. Run the following command "kausrtsk  -remote" without quotes. Try to redeploy again.

  • I did a deploy without  lan watch, using a vb script to copy the file, and then executed it from wmi calls.

    It worked great.  That way I could feed in a specific list of PCs and deploy it.