Kaseya Community

Error when on the script

This question is not answered


I am trying to install a software on a pc through kaseya.

I have done this script on 2 other software and it was working fine but for this , it did not work.

These are the screenshots:

I can see that the file was successfully transferred on C:\Temp.

On Line 5 , I tried both  Execute as System and Wait  and  Execute as System and Continue but still same error message.

Is it because of the location where it will be installed?

Thank you in advance for the help  :)

All Replies
  • It’s because of the path you’re writing it to vs the path you’re executing it from does not match. You’re writing the file to C:\temp but trying to execute it from the appdata folder

  • You are downloading the file to the temp directory but your exectuing the file out of the app data folder... why? The execution file path should be the same as your destination path from the previous step.

  • Thanks @csmith and @Corey Crossman. This is fixed, I used the default location which is #agentDrv#temp\pyRevit_4.7.4_signed.exe and I changed the privileges to Execute as user and wait.

    All good :)

  • Just remember... if you "Execute as user"...

    * User must have authority to install

    * User must be logged in at run time OR

      - Use a credentialed user or impersonate user in a step ABOVE the step that executes as "User".

    Execute as System provides elevated authority on a local machine... but System has NO Network authority.  As is, your script will work as System... but if you were copying the file from a Network Share, "System" user would fail trying to access the NIC to get to the Share.

    Execute as and when it fails or succeeds can be one of those simple things that can really screw you up if its not clear.

    Hope this helps.