Kaseya Community

Agent Endpoint service terminated...procedure could not be fund....event ID 7024

  • Hi all,

    I am just starting to roll out Kaseya agents to Windows 7 workstations. I ran into a few issues but nothing I wasn't able to fix until this specific workstation. It keeps automatically rebooting itself. I check the log, and every time right before it reboots, I see this error:

    Service Control Manager - Event ID 7024

    The Kaseya Endpoint service terminated with service-specific error The specified procedure could not be found..

    I I uninstall Kaseya from the command line, the auto-restarting issues goes away. However, every time I reinstall the agent, I have the same issue. I don't see anything in the agent logs that is useful to troubleshot this issue. Has anyone else ran into this? Anyone have any suggestions? I don't want to continue to deploy the agents until I have this resolved so that I don't risk running into the same problem with additional workstations. Thanks!

  • If you delete the agent from the VSA and then reinstall does the workstation continue to reboot?

  • I don't know if you're still seeing this but I think I just fixed this by copying this file from a server where the endpoint was running to a server where it refused to run with the same error you specified:


    It may be too soon to say for certain that everything is working as intended. I don't know what the purpose of that file is or what settings I may have inadvertently copied over. I do know the service is running again.