Kaseya Community

Agent Disappeared from VSA - Agent not recognized by KServer

  • Has anyone ever had an agent disappear for seemingly no reason?  Today I attempted to check something on a customer's server and noticed that it wasn't listed in my VSA.  I logged on to the server to check the agent.  When I hover over the system tray icon, I get the message "Machine ID.Group ID not recognized by the KServer".  I have the locked down the ability to remove agents from the VSA to just a few admins and I confirmed none of them made any changes.

    This is very concerning because I just happened to find this because I needed to check something.  I am really worried that I am losing other agents that I am not aware of.  I suppose I could re-install the agent from scratch, but that doesn't answer the question of what happened to it in the first place.  Even if I just did that, I am going to have to repeat a lot of work that I already completed to configure the agent.

    I opened a support ticket, but I wanted to reach out to the community as well.  Has anyone else seen this?

  • I've seen that 2 times and it's typically because the KServer has either max'd out it's license or SQL server is not fully patched. Have you checked both of those?


  • Good on both.  I saw some old posts with folks getting a similar error and the license problem was suggested, so I checked that out just to be safe.  I also confirmed that I have no applicable SQL patches.

    When you have seen it before, was there any option to re-install the agent with all the existing settings?  I am likely going to re-install the agent because I can't let a server go all weekend without a working agent while I wait for a follow up/resolution.  Being that it's a server, and I can't create a re-install link,  there is a significant amount a configuration that I will need to repeat.

    Before I install a new agent, is there any logs, files, or screenshots I can collect to help determine why this happened and help prevent it from happening again?

    This is situation is making me really worried about this happening again and the overall reliability of the product.

  • When I've seen it happen, usually an agent reinstall doesn't resolve the problem, there's typically something causing the agent to not install. You can also check the error logs in the kaseya install directory. It's possible something may be blocking the connection and if so you'll get something like a -12 or -11 error. Also, I've never seen the agent uninstall itself from the VSA console. Support needs to take a look.


  • Thanks, Max.  Can you help to get someone to follow up with me as soon as possible.  I can't let a server go all weekend without a working agent.  I called and spoke to someone in Support, but I didn't feel very confident in the response I got.

  • Sorry, I'm in a different office and don't have any control over support.  Have you tried removing and re-installing the agent?


  • I didn't necessarily want to uninstall and re-install the agent because I wanted to be able to find and prevent the cause of the issue, but after nearly 5 hours and no response from support, I had to try something so that I didn't have a server without an agent all weekend.  The re-install worked and I spent the time to re-configure everything.  I am still pretty worried about this happening again, though.  I made copies of the working directory and the Program Files directory, so hopefully something can be found from that.

  • eperson, are you sure you saw the agent in the VSA at one point, or did it never check in?

  • kuuser

    eperson, are you sure you saw the agent in the VSA at one point, or did it never check in?

    Yes, it was first added on September 6th of this year.  It was in the VSA as late as yesterday.  I spun up a VM using a backup image of the KSERVER so I could review what scripts and monitor sets were assigned to it to help speed up the process of re-configuring the agent.

  • On the endpoint has the KaseyaD.ini even been processed... or is it still showing a template version

  • if it has processed the kaseyaD.ini I would look at the system log in the System > System Log and look for that machineID under the description. Should provide more insight.

  • Hello Flavio.  It had been checked in for several months before disappearing, so I don't think that it would show I template version.  I did make a copy of all the files before uninstalling and re-installing a new agent, so I could check if you think it's pertinent. How would I check that.

    I am pretty disappointed with the response I received from support. I made the ticket around 10:00 AM, Friday and followed up with a call to make sure it was set as a high priority.  My first response was about 70 hours later, this morning and that was just an email stating that the ticket was assigned to someone.  Has the Kaseya support staff been cut back?  The response from the person I talked to on the phone was a lot less professional than I have experienced on previous calls as well.

    Fixed Typo
    [edited by: eperson at 11:46 AM (GMT -8) on Dec 22, 2014]