Kaseya Community


  • Hi,

    I am on kaseya cloud version.

    I have configured KDB to use private storage as D: drive of that machine being backed up and set the credentials as a local admin account.

    But when I test the results it shows as  "No response from the Private Storage server. Confirm that the backup location is correctly configured. Consult the PrivateStorage.log in the Agent directory."

    What might be causes??

    agent credentials?? or else?

  • yogesh,

    few questions which you can try:

    -have you set up storage correctly

    -Have you set up port correctly ensure that port is not in use.

    -have you assigned storage while scheduling backups.

    AND anything else or any error if you can share


  • @Yogesh.  I believe I'm confused about your setup, can you clarify?  You want to store the data on the same machine as you're backing up?  In other words, let's say as an example you have MachineX and you're backing up the My Documents folder which is on the C drive.  You want to backup those files to the same machine, MachineX on the D drive?  And as such, you are using the agent to both send and listen on the same port?  Is that correct or am I misunderstanding your setup?

  • Max, what do you mean when you say send and listen to same port. is there a place to set up send and recieve ports separately. I see only one and i assume that is for both way.

  • When it comes to Kaseya Data Backup, you specify where you want the data off-sited to.  You can either use Kaseya's built in storage facility (leveraging Amazon's S3 cloud) or setup your own private storage.  If you setup your own Private Storage then you need to have an agent on your off-site location that will accept the data.  The off-site agent requires it's own port.  Are you sure you're using Kaseya Data Backup and not one of Kaseya's other Backup products?

    To confirm what you're doing.

    1) Click on Data Backup

    2) Click on Private Storage

    3) Select the machine you want to be your private storage server

    4) Enter the IP for the machine

    5) Enter the Port

    6) Enter the location on the private storage server  where you want to save your data

  • Max to follow up further on this, I see that KDB works well when it is backing up to local disk or to kaseya cloud. But when clients have their NAS and configured as you  explained in 6 steps above it fails. I was helping someone on SAAS plateform and ended up opening a support ticket. The support guy worked on it and after working for a week or more escalated to engineering team. Another thing (surely development bug) I figured out during this troublshooting that the KDB logs on agent were showing all storage server passwords as plane text.

    Can you please try above steps (if possible) at your end to a NAS and let us know if that works for you?

  • I was using KDB in my personal test environment and unfortunately my Buffalo LinkStation NAS died on me a couple weeks back.  As soon as I get another one, I'll try the KDB setup and post the results.

  • Hello,

    I am having similar issues, however when attempting to backup to a NAS device:

    When attempting to test the private storage we receive the following:  "No response from the Private Storage server. Confirm that the backup location is correctly configured. Consult the PrivateStorage.log in the Agent directory."

    However when we look at the file structure on our NAS device, we see that KDB has created folders and sessionkey.txt files.

    Since folders and files are being created this signifies to us that the NAS storage and network firewall/port forwarding settings are setup correctly.

    We attempted to run a data backup set and it stalls at 6%. The error says  "The agent stopped communicating with the server for more than 10 minutes"

    Can we please get some insight as to why the connection between KDB and our NAS device is failing?

  • @brummble78 :Have you got any resolution for the above said issue. If so how it got resolved.

    We are also planning to setup a similar kind of environment to backup the files to the private cloud over the WAN.

  • I am attempting same set up and get same result - I have tried as UNC path and also mapping the NAS as a drive on the server then using the drive letter in set up.

  • sorry for the delay in reply, must have missed the email alert until nick replied.

    What we were told by Kaseya support was to update the agent on both the backup machine and private storage. That seemed to work for us.

  • ^update the agents even if they are on the most current version