Kaseya Community

Policy - Out of Compliance

  • We have the same issue as Sander.

    Created a ticket but no solution yet.

  • I have a ticket open as well, since 2 days ago.  So far they logged into my system, and escalated the ticket.  Now just waiting for the next level to look at it.

  • I have noticed this as well. I have machines applying automatic Windows updates randomly now, when I had 0 issues before 6.3...for the same out of compliance reason. I reapply the policy and the setting is corrected. This becomes a HUGE issue because we do NOT support IE10 and it has been popping up on machines randomly.

  • grumple
    As of today, my server has started to mark every single "Alert" policy as the reason it's causing all my machines to be "out of compliance."  And since I have several alerts setup on all machines, they're now all out of compliance, and I can't clear it.  Any ideas what might cause this?

    Last night, we released a hotfix to address this issue.  The hotfix also addresses a similar issue with monitor sets.

  • Kaseya placed a temporary fix on our server and the problem looks solved.

    Answer from Kaseya:

    This is an issue we are currently aware of. I applied a temporary fix on your server. Simply re-process the policies for all the machines missing the Monitor set. Do not reload your hot-fixes or run a reapply schema till the permanent fix is released because this will remove the fix and we will have to reapply it. Our development team is working on a fix at this time. Please be patient.

    So if you have problems just add a ticket

  • Hello Brzzl,

    glad to hear the problem is fixed. Do you have a ticket number?

  • Ticket number is CS155810

    Kind regards,


  • Thank you Brzzl, will refer to this ticket in mine.

  • The hotfix fixed the issue for me.

    [edited by: grumple at 6:53 AM (GMT -7) on Apr 12, 2013] Corrected statement
  • I thought it was fixed -- I was wrong...

    So, like everybody else, I ran a compliance check and it appears to fix the issues we have all described.

    To be sure, I changed the working directory for a server and ran the compliance check. The result... the server is in compliance. But the working directory is not what the policy says it should be so it is really not in compliance, even though it says it is.

    I am on the phone waiting on tech support to pick-up. I do not know if this problem is specific to my server or not.

    I should have said this earlier... I have the on-premise version, I run my own server.

  • After more testing than I would like to admit, I feel comfortable making the following statement...

    Policy Management, specificly, compliance checking, does not work. I change the working directory on a server that is different than the poicy setting. The comjpliance indicates it is in compliance.

    I also set the schedule to deploy the policies every hour. Now, the server that I changed the working directory on, is out of compliance and the out of compliance setting isn't the working directory like you mnight think, it's the Agent Core/Checkin.

    I think I'm over it - policy management is useless.