Kaseya Community

Policy Management: Policies not applying

This question is not answered

Please let me know what I'm doing wrong here. I've followed the documentation provided here and it just isn't working.


I created a policy, created my desired settings and assigned it to a view. I found a machine in the organization/machine group "unnamed.root" (just for testing) which can be located using the same view on which the polices are based. I assigned those policies to the organization/machine group "unnamed". The scrolls are white indicating I've saved and applied the policies. Nothing happens. What step did I miss here? Even if I manually assign the policy to the machine it doesn't actually apply. The icon next to the machine indicates nothing is applied to it.

All Replies
  • there is a number of people on this forum complaining about the same thing

    have you logged a ticket with kaseya

  • Tony make sure you have all the latest updates applied to your server.  There have been a load of patches released lately for KPM.

  • Anybody having better luck lately?  I'm finding that either policies aren't applying to sub-groups within an org that has a policy assigned, or they're applying at random to machines within those groups - but never all of them.  Agents also show out of compliance for various reasons and never update, or when i change or remove a policy the machine doesn't reflect so. I haven't been able to apply hotfixes now for at least a week but hope to soon.  Maybe the KPM hotfixes pending will make the difference I'm looking for.

  • We are having a lot of KPM issues.  It has been causing us a lot of problems and seems to function whenever it wants.  Very unpredictable.

  • did you have any luck with this, I decided to try out Policy mgmt and I create a simple policy with one script, I applied to an ORG and nothing, waited for nearly 24 hours and its not applied and dashboard says none applied. I set the update time to 5 minutes but still nothing yet if I click on the policy and look at machine groups it is applied to the selected machine group is there. All hotfixes applied...

  • I have the same issue my side.

    Event logs Policies not been applied at all.

    Some Service alerts been applied to the wrong machines.

    Gone through and removed polices and tried to add them again, but they do not get applied at all.

    Logged a job with Kaseya support just after the 6.2 upgrade about the issues and still trying to get it all fixed.

    Started applying the policies manually again, though I have a feeling this is not working either or applying correctly not getting alerts I know I should have got.

    One of the main uses “proactive alerting” is not working correctly or at all.

  • I have a similar issue at the moment - not identical though. I have a set of policies that get applied to a machine, and one of those policies' alerts has a blacklist event set within it (2 down from the top in a list of about 8 event log sets.)

    This event set seems to override each and every other event-log based event set that is applied after it, very peculiar indeed, and if i change the order of the policies then only the very first policy's event sets seem to apply, the others are all ignored.

    I have an ongoing ticket with Kaseya regarding it... Will let you know if they find anything. They did send me an updated set of dlls for policy management alerts and remote control, but this hasn't made any difference in my case.

    [edited by: Phil G at 5:14 AM (GMT -8) on 12-1-2011] Grammar
  • I found that manully clearing override then reprocessing gets it working initially. Once processed changes are getting applied automaticlly to all endpoints.

  • I have the same problem. My test policy is not applying to the machines as defined by the selected view ...

    I have a view that selects all computers with a very specific .exe installed (only on my computer). I created a policy that will only change the settings on the Agent Menu and add once single scheduled agent procedure. So, nothing fancy. I save and apply the policy settings, the logs says it's done, but the policy matrix shows that the machines (only mine, really) in the selected view does not have any policies assigned.

  • If you look on the machine itself, does it have the changes applied or not? Meaning are the policies not applied or is the matrix just wrong (I had this issue once)


  • I had the same issue. Created a ticket at support and they acknowledged the problem.

    workaroud for that is to add the monitorset at the server itself.

  • Heh, that's less a workaround, and more just pretending policy management doesn't exist! :)

  • Having similar issues to this:

    Agents also show out of compliance for various reasons and never update, or when i change or remove a policy the machine doesn't reflect so.

    I'm also having odd behavior with KPM in that some machines just fall out of compliance for no apparent reason and their settings change. For example, with no user intervention the scan schedule for some machines just goes bye bye. If I manually reapply the policy it comes back, but honestly why the hell is this happening?

    I've got a ticket open, but like most tickets it's taking some time to get answers.

  • Clear override and re-apply worked here. In fact, I went ahead and did this to all agents regardless of if I have got around to putting policies on them. Only took a second to do all agents so it's not very database intensive.

  • Doing what ghetto mentioned works, but why do I have to do this? Why are machines magically falling out of policy to begin with? It's really a second we shouldn't have to take since this is what the module is supposed to do.