Kaseya Community

"A website wants to start a remote connection" security dialog during RDP Desktop Access

This question is not answered
Any way to get rid of this infuriating dialog everytime I use RDP Desktop Access? I know why it's happening but can't figure out how to change the behaviour so it doesn't pop up all the time. Not too interested in VNC if that's your best shot though, sorry. Thanks.

[edited by: TEAMnetwork at 1:47 PM (GMT -7) on 10-28-2011] Change to question
All Replies
  • On WindowsXP, in the "My Computer" - "Properties" - "Remote" tab you can set it to allow all connections and "Allow Remote Connections to this computer". There's probably a registry setting somewhere that will do this as well. In Windows7 it's in "My Computer" - "Properties" - "Remote Settings".

  • At least part of the registry key is -

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server". The Key is a Reg_Dword - "fDenyTSConnections" set to "0" to allow remote desktop connections.

  • What am I missing here? This was already set and I'm still getting the prompt. Thanks

  • Also, client is Win7. Don't think I get this on 2003/XP anyway

  • Very strange. What do you see when you click on the "Advanced" button?

  • Does this apply to your situation?


  • Advanced only refers to Remote Assistance, not Remote Desktop. Nothing in there anyway,

    I also tried adding "Everyone" to the "Select Users" thingy but apart from not making any difference that would be a major security hole.

    The issue seems to be related to the fact the request is coming from localhost, and my understanding is that there is some SSL communication going on with an unverified, non-certificate matched source. This is happening on multiple Win7 x64 machines, not sure if other client platforms are similarly affected., but Win7 x64 is the only one we use.

    Might have to open a ticket. Urgh. :o(

  • Yeah I saw that a several other similar articles but none make any sense because the request, according to the dialog, is coming from localhost and there is no certificate that matches that hostname. There is a local certificate for the fqdn machine name but that's not where the request originates so I gave up at that point.

  • Does this setting make a difference for you?

  • Unfortunately not. I did change the default.rdp settings anyway. I also tried spawning the KLC as a http instead of https session but that didn't seem to have any effect either.

    Would be most interested to know if other people are having this issue and ignoring/putting up with it or not having it at all, particularly on Win7 x64 clients.

    Thanks for your ongoing interest zippo. Appreciate your time.

  • Just a shot in the dark here, under LGPO check (User Config > Windows Componets > Remote Desktop Services > Remote Desktop Connection Client >

    Allow .rdp files from unknown publishers > enable

    I'm not sure if this will fix it, just a shot in the dark.