Kaseya Community

Install failed, reboot may be required.

  • i am constantly and almost consistently getting the above error code, more often than not as of late. it seems self explanatory but does anyone actually have a fix for this. here are my steps:

    reboot, thought KAV

    Force agent update in the VSA

    ensure windows patches are all current

    verify everything is cleaned off of the machine, from registry to programdata

    restart it from within windows

    restart any kaseya services

    refresh all audit data

    restart once more in kav

    ...still nothing.

    For the most part these are fresh installs, the occasional upgrade from classic is mixed in there. i am on R9.3 patch 21

    [edited by: ndaddona at 8:00 AM (GMT -8) on Nov 7, 2016]
  • Could you provide screenshots?

  • this is what shows up on the details. within the kav module itself, it just says 'installed failed'

  • +1 - I am seeing exactly the same thing.

  • Good morning and , have you gotten any further with this?

    I am plagued by the exact same thing. Sending a polite install prompts the user and this shows in the AP log, but then the install fails immediately after that. No install files are even transferred from the Kserver to the agent.

  • hey i have not had any luck on my own. i currently have a case open that is waiting on assignment

  • Let us know the outcome of your case.  New KAV has the logs in a different location and may or may not be of some use.  I did encounter this issue during beta testing and honestly left it alone.

  • Hi ndaddona,

    We put this error when we received a 1603 error back from Kaspersky/Microsoft installer and have found that a reboot usually clears up the issue.  

    Here is the microsoft kb article if you are interested: support.microsoft.com/.../834484

    If a reboot does not work, is there currently Kaspersky installed on the machine?  If so maybe uninstall this first.

    Another thing to try is to run the installer manually on one of the endpoints.  This may give more details than we are receiving back from our install process.

    Please let me know how it goes.  You can always ping me at charles.custer@kaseya.com and I can set up a GTM with you if you like to look further into this.

  • I think Charles is right..got the same error today, machine had done windows updates but not rebooted....quick reboot fixed it up.

  • we have verified these steps as charles and craig mention, and that is not the issue.

    i have a support case open and they are mentioning the same thing, that the "Install failed, reboot may be required" status in the VSA seems to be directly related to a 1603 error. we were able to confirm that everything is 'clean' from a human perspective. our next step is to run the Kaspersky

    GSI tool to see what Kaspersky thinks is blocking the install.

    my big complaint coming out of this is: can the VSA report something a bit more robust? seems very generic.

    can Kaspersky get us a CLI tool for this GSI Tool, as far as i know it has to be run manually...defeating the purpose of using this AV product for MSP

  • You can script the GSI tool to execute and collect information back to the agent (which is a bulk of the work).  Next step is to upload it to the site for analyzing.

    There have been plenty of discussions of better and more robust logging.

  •  i thought the GSI was dependent upon user interaction to accept a EULA or something?

  • Hi ndaddona,

    I have created a ticket to look into ways of possibly getting GSI information via the VSA.

  • Check the link below out:


  • Good day,

    I'm not sure if there was any resolution to this. I have had the same issue on multiple machines. I did eventually get it to install. We ended up downloading the trial version from kaspersky's site. It ran a prerequisite check and found that symantec was installed (which is wasn't in every case), it removed the component and rebooted. After this, I was able to deploy Kaspersky through the normal process.

    Hope this helps