Kaseya Community

"Could not add job to scheduler" New Error on two machines?

  • I am down to my last few computers to move over from classic.  The issue first came up with the error to remove the clasic first so did that.  New install did not work still.  So in another post I saw about deleting the agent but leaving not removing the agent so it will check back in.  That is where I am stuck now with this error in the KAV interface.

    Could not add job to scheduler: Agent has not been provisioned yet. Could not get EndpointId with given assetId (########################)
  • Having the same issue.

  • This link might be helpful...



    Definitely helpful, I would recommend creating a support ticket attaching the logs referenced, as the condition can vary from server to server.

  • I am glad it only seems like two computers.

  • Here's what I did to resolve on a PC just now. Uninstall MBAM and KAV classic (I had to reconnect these first). Uninstalled agent. Manually deleted all Kaseya folders from PC. Rebooted. Reinstalled agent. Reinstalled KAV then MBAM. Worked like a champ.

  • I'm having the same issue here.

    Twistedtechmike solution ("Uninstalled agent. Manually deleted all Kaseya folders from PC...") is quite wild... (no offense, it definitely works for you) I would think that should have another more 'normal' solution for this. If one needs to remove everything and then re-install all, it's not a solution, it's just like when you buy a new computer and install Office on it. Can Kaseya give us a better option?

  • ,

    There is a KB article you may want to check:  helpdesk.kaseya.com/.../229014868

    If that does not address the issue, I recommend you open a ticket so Support can investigate and address.

  • Ive only seen this issue once more since I posted and had to follow the same tactics. It was an older machine which was never rolled up to the newest version.

  • This solution fixed it for me. https://helpdesk.kaseya.com/hc/en-gb/articles/229014868

    Thanks :-)

    Inserted Link
    [edited by: cjruss at 6:49 AM (GMT -8) on Nov 10, 2016]