Kaseya Community

KAV profiles not working after upgrade

  • We upgraded to V6.5.  At the moment none of the profiles work.  Just get an error.  Logged a skupport call, and yes it is a problem with the upgrade, and no there is no ETA.  Cant install due to I can not configure V10 profiles.

  • Can you provide more details on the error itself?

  • This is what we get looking at V6 or trying to create a profile

    Object reference not set to an instance of an object.


    at Kaseya.SecurityCenter.Web.Controllers.KAVProfileController.InspectorIndex(Int32 id, String name, String type)

    Exception has been thrown by the target of an invocation.


    at System.RuntimeMethodHandle._InvokeMethodFast(IRuntimeMethodInfo method, Object target, Object[] arguments, SignatureStruct& sig, MethodAttributes methodAttributes, RuntimeType typeOwner) at System.Reflection.RuntimeMethodInfo.Invoke(Object obj, BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture, Boolean skipVisibilityChecks) at System.Reflection.RuntimeMethodInfo.Invoke(Object obj, BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture) at System.Reflection.MethodBase.Invoke(Object obj, Object[] parameters) at Castle.MonoRail.Framework.Controller.RunActionAndRenderView() in e:\trunks\castlesvn\MonoRail\Castle.MonoRail.Framework\Controller.cs:line 1683 at Castle.MonoRail.Framework.BaseHttpHandler.Process(HttpContext context) in e:\trunks\castlesvn\MonoRail\Castle.MonoRail.Framework\BaseHttpHandler.cs:line 96

    Error processing MonoRail request. Action inspectorindex on controller kavprofile


    at Castle.MonoRail.Framework.BaseHttpHandler.Process(HttpContext context) in e:\trunks\castlesvn\MonoRail\Castle.MonoRail.Framework\BaseHttpHandler.cs:line 116 at System.Web.HttpApplication.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)

  • I've forwarded this over to our support team, but please be sure you create a support ticket if you haven't done so already.

  • Do you have the ticket number by any chance?

    Yann (Kaseya)

  • Ticket 3633.  

  • gdoub,

    I sent you a PM.

  • I had the same issue yesterday after we upgraded to Version 6.5. I created a ticket and within 30 minutes Andre was on phone assisting us. As a matter of fact, Tito and Raymond were also on our meeting to get it working. While the upgrade appeared to go smoothly, it did not complete the installation of patch properly which created many issues. All three worked the problem yesterday afternoon for several hours. They had dev involved too reviewing the patches and the installation process. They must have started around 1:00 pm and were done a little after 6:00 pm est.

    While it was unfortunate this occurred and perhaps they will be able to further determine the problems, (was not my hardware or OS), they jumped on the problem almost immediately and did get it corrected.

    I AM VERY HAPPY WITH THE LEVEL OF SUPPORT WE RECEIVED!!!! They could not have done it better! I watched the process while doing other work and my staff also did other projects while this was happening. They worked as fast as they could and in the end uninstalled almost all my modules and re-installed one at a time.

    Today, I am working on KAV profiles and it is alot of work to rekey trusted sites, paths and urls. The copy function from a 6.0 profile to a 10 profile does not work as additional features are grayed out if you copy an older profile. The only answer is to create a new profile.

    In the end, Kaseya did an excellent job! Keep up the good work K-Team!!!

  • The profile issues got fixed with a hotfix last night.  Applied and now work

  • Excellent news, guys!

  • gdoubinin,

    which hotfix is that? we are on but still have troubles applying KAV 10 workstation profiles, no matter brand new or copied from KAV 6.

    KAV 10 server profiles seems to be working well though

  • We are on and still having issues with the KAV10 profiles.

  • As are we!  Gone almost a week without contact and the last two communications from the assigned technician just state that the engineers are looking at it and he will let us know when its resolved...Not acceptable in my opinion after I made it clear the impact this issue has on us servicing our clients etc. :(

    .Ticket  number for ours is:  #4123....

  • Just applied the,reapplied the schema and  tested the profile issues.  Surprise surprise, the issue remains and we are still unable to update or deploy KAV/KAM to our endpoints due to the inability to select a profile and we also still can not create new profiles in either module.

    Just called Kaseya support referencing our ticket 4123 and informed them the issue remained after applying the patch which they informed me was going to resolve these issues.  All I got was the standard "our engineers are still looking at this and we will let you know when a patch is released to fix it".

    Is there ANYONE from Kaseya that can look into our ticket and get us some actual support?!  This is especially frustrating because it appears others in this thread have had the same profile issues and had them resolved by support....

  • We are in the same boat on our lab 6.5 install. This was the last piece in our testing before moving forward and have spent almost two full days trying to get profiles or license keys to apply. Any information that is found out would be greatly appreciated.