Kaseya Community

discovery - deep scanning ( never ending story )

  • Hi,

    just checking whether somebody is seing the same behaviour in discovery.

    deep scanning seems to never end ? ( already tried replacing the winpacap version but nothing changes )


  • Hi  

    Can you provide more information on the issue?

    What type of OS are you trying to run the discovery scan on?

    Are you able to provide a screenshot of the agent procedure log that shows what is happening during this procedure?

    Are any .XML's created in the C:\working-directory\LAN Watch Folder? If so, are any errors indicating why the scan may be getting stuck?

    Best Regards,


  • Hi Nicolas,

    sorry for the delay with my response but have been working on our R8 --> R9 migration and somehow hoped that this issue would be resolved in R9 but it doesn't.

    don't know whether I undertand your question !! It's the integrated "discovery" within Kaseya so I don't have created any special agent procedure. I checked on our KNMGateway server and don't have any xml files in the working directory ??!!


  • Hi,

    still problems with the discovery ( deep scanning seems stuck ) Scanning is done using 2008 windows servers.

    I already tried by excluding the executables in the symantec endpoint, but nothing changes.

    however for one of our clients the discovery is not working. ( no devices printers....found ) In the agent procedure log I noticed that the nmap.exe is done an --exclude but this client is using 10.0.0.x ip's addresses !!


  • Hey  

    Server 2008 is a compatible OS with the Discovery scan, so it should be able to complete.

    The scan getting stuck in deep scan stage indicates, that the machine has a problem when running nmap.exe - as the deep scan kicks off nmap.exe.

    Are the following files being created on the machine?

    IF yes, then review the .XML's and it should show what is causing the failure.

    If you are unable to find a root cause, please create a help desk ticket and let me know the ticket number and I can assist.



  • Hi Nicolas,

    thks for your reply.....

    Client Buhlmann Server Backup01 having problem

    see below contence of the lanwatch folder.

    tickets 63454 / 69490 / 81448....


    folder called @MsgQueOut ( access denied )

    folder called temp containing 1 dns-unk / 4 nmapos and 1 nmapps out

    and 1 file called discovered...


  • tickets 63454 / 69490 / 81448

    client Buhlmann server Backup01 temp folder containing 1 dns-unk / 4 nmapos and 1 nmapps-out