Kaseya Community

Agent Machines showing up with barcodes

  • In this trainwreck called Discovery, I'm attempting to get all my networks in order so that I can then resetup KNM that broke after the KNMi upgrade.  Anyway, when I run a scan of any of my networks, I'm detecting all the machines/switches/whatever on the network and they show up in the Grid View.  The problem is that only about 4-5 of the machines on any network shows up as being a machine with an agent installed.

    soooo, when I go to install a KNM gateway, I only get those few machines in my options of where to install it. And, invariably, the machines listed are laptops and such.

    Any ideas out there on how to get the discovered devices that have agents already on them to show up as such?  I've reran scans of the network, I've reran every Audit option available, I've restarted the KNM service.  All for nothing.  KNM is quickly becoming a non-starter for us.

    Any ideas appreciated.


  • Hi Jeff,

    I would recommend submitting a support ticket on this matter and referencing this exact information.

    Once devices (specifically agents) have been deleted form the Discovered Devices - Grid View page, they will not return until the agent state is kicked. This can take some time and support can provide you the information to expedite this process.

    Kind Regards,


  • Hey Nicolas,

    This issue is really killing me.... I've spent two weeks trying to get KNM and Discovery to work...

    I've submitted a ticket, but if it follows the trend of my other 7 tickets I have in, it will be 3 days before I get any type of answer. Can you PM me what I need to do? Or help expedite the process? That ticket number is 55626.

  • I have the same issue...

    I have 5 tickets open, all KNM.  Primary ticket 27999

    Added ticket number
    [edited by: Tim Varvais at 8:15 PM (GMT -8) on Nov 26, 2014]
  • Me too. I ha ve the same problem

  • Same here. We had this issue when we first upgraded from 6.3 to 7 and had to spend weeks for K support to somehow fix it! We are now on version 8 and encountering same problem. The thing that concerns me the most is that if this is a known issue which seems to be the case why isn't there transparency from kaseya support!!!

  • An UPDATE,

    I had to run System->Server Management->Configure->Reapply Schema for another ticket we had open with Ksupport (unrelated from this issue) and noticed the discovery detected agent installation and replaced barcode with agent symbol.

    I did try it again with two groups and result were the same. I've advised the support to see if it can help them identify the issue but for now it seem to resolve the problem.

    Do note that running reapply schema will TAKE KSERVER OFFLINE while it runs.

    Pls use this info as is!

  • Thanks Sam, that worked for me. Luckily this is on a test server so I could do the Schema update when ever I wanted.