Kaseya Community

requestTimeOut Queue error - need to move sql

  • We have had problems since upgrading to k2 with CPU. It was at 100% utilization for hours, and of course the interface was slow. I configured SQL to only use the second core, and it was ok for at least the last few days. We upgraded a couple of weeks ago. Beginning Thursday evening through Saturday morning CPU core 1 (SQL) has been holding steady at 100% and the interface hasn't worked. It was extremely slow, but we could still manage to maneuver enough to configure a few things. At this point we only get the error below after logging in. RequestTimeOut Queue:: User IP:: 127.0.0.1 Seconds::30 I've narrowed it down to the kaseya messagesys service. It stops after 5 minutes or so and CPU drops, but when it's running CPU is completely pegged. So at this point I'm configured another server to move SQL to. The only question I have now is how do I move SQL to another server when i can't get into the kaseya interface? Is there a way to do it on the backend or do I have to reinstall. My ticket number is CS011639, but now it's Saturday and support has limited off-hours coverage. I need to get my system back up before Monday. Has anyone else seen this error and have any suggestions?

    Legacy Forum Name: requestTimeOut Queue error - need to move sql,
    Legacy Posted By Username: runnetworks



    [edited by: Anonymous at 3:24 PM (GMT -7) on 4-11-2011] just
  • Hi,

    We have had similar situation.

    Go to the agent check in and change the check in port temporarily to stop agents coming in to your K server and the CPU should be normal.

    I even got the database .mdf file copied from old SQL server and added manually to new SQL which worked just fine. I had to reapply the schema though.

    Also, you can manually take the backup for SQL and restore in new SQL.

    So let me know if any of these three options works for you.

    Legacy Forum Name: General Discussion,
    Legacy Posted By Username: mnagra
  • I finally finished the new SQL server setup, but had to reinstall k2 on the original single server to fix the GUI, then was able to move the database to the other server. Still haven't heard from support since Friday afternoon.

    The new SQL server is on an ESX server, but I gave 2 cores dedicated to the SQL server and it still maxed out CPU. It looks ok now with all 4 cores assigned to the SQL server.

    At this point, I'm very surprised at how much CPU SQL demands for kaseya. I have other SQL servers configured that don't require nearly this much horsepower.

    I blocked the kaseya agent port and offsite back ports for around 24 hours and cpu was still out of control.

    Legacy Forum Name: General Discussion,
    Legacy Posted By Username: runnetworks