Kaseya Community

Screwy Scripting after SP1 update

  • After updating to SP1, when I run scripts against machines, it no longer displays an entry under "Next Scheduled Run" in yellow like it used to. It also reports almost instantly that the job is done even though its clearly not complete on the workstation. Does anyone know if this is by design? Its making it very hard to determine if scripts are actually done, or still in progress now.

    Legacy Forum Name: Screwy Scripting after SP1 update,
    Legacy Posted By Username: efieric
  • efieric
    After updating to SP1, when I run scripts against machines, it no longer displays an entry under "Next Scheduled Run" in yellow like it used to. It also reports almost instantly that the job is done even though its clearly not complete on the workstation. Does anyone know if this is by design? Its making it very hard to determine if scripts are actually done, or still in progress now.


    If you bring up the Machine Summary (by clicking on the green OK diamond), what is displayed on the Pending Scripts tab?

    Michael

    Legacy Forum Name: General Discussion,
    Legacy Posted By Username: RCS-Michael
  • It shows the pending scripts on each station yes, but when you have a view defined and you are pushing out an application to 20 machines it was nice to be able to see in the list who completed with a successful install and who hasn't. It works properly on rare occasion. I understand that some scripts will complete quickly while the commands run on the workstation still. But it used to wait for exe and msi installs before reporting success.

    Legacy Forum Name: General Discussion,
    Legacy Posted By Username: efieric
  • I can confirm this same behavior on my kserver after applying SP1.

    But I found that if I choose Schedule, and set the time to 5 minutes ago, it behaves as before. So that is a temporary workaround.

    I reported the issue, and opened a ticket with Kaseya support.

    Lloyd

    Legacy Forum Name: General Discussion,
    Legacy Posted By Username: lwolf
  • If you beleive you are seeing any strange schedule activity since upgrading you should contact support at www.kaseya.com/support and report it. Ensure that your agents are updated to the latest version under Agent->Update Agent, as that could effect script execution.

    Legacy Forum Name: General Discussion,
    Legacy Posted By Username: raybarber
  • We were getting a lot of performance related complaints about this page prior to SP1 so we changee the SQL to speed it up. A bug creeped in there that failed to display pending status when Run Now was clicked in some cases. The Schedule button worked fine. We have posted a hotfix to correct this behavior in all cases.

    Legacy Forum Name: General Discussion,
    Legacy Posted By Username: Mark.Sutherland
  • You have no idea how happy I am to see you Kaseya guys posting. SmileSmileSmile

    Thank you for the updates.

    Legacy Forum Name: General Discussion,
    Legacy Posted By Username: CeruleanBlue
  • Mark,

    Fix seems to be working. Thanks!

    Lloyd

    Legacy Forum Name: General Discussion,
    Legacy Posted By Username: lwolf