Kaseya Community

On premise: Was anyone successful in integrating a working Remote Desktop Access?

  • Hello Everyone,
    For us that run environment with low bandwidth (VSAT) Kaseya Live Connect isn't working (freezes, does not connect and when it does it is super slow, resource hungry, need to install live connect etc.)

    We are experimenting with a much more advanced system (free and open source: Apache Guacamole) that allows you to remote access any of your machines and it is entirely clientless (you just need a browser to access your machines) and would love to see it integrated in Kaseya so you don't have to jump out of kaseya in another system just to remote access a machine.

    Has anyone done anything similar and got it working?

    Apache Guacamole has a document to integrate it into other systems but before we delve into that, may be someone already did it :-)

    Thank you

  • KVNC is low bandwidth, RDP too. (In the Legacy/Classic remote control module)

    i.e. http://help.kaseya.com/WebHelp/EN/VSA/9050000/index.asp#443.htm

    We also sometimes use a reverse ssh tunnel for RDP via a kaseya procedure.

    I'm curious though. Why do you think Apache Guac is "much more advanced". Sound to me like you're just flexing. Stick out tongue

  • Hello myArch-man,

    Thanks for your answer.

    I am aware of the RPD and VNC remote control feature in Kaseya.

    In-fact this is what we had been using in place of KLC and you are correct those work much better in Low Bandwidth (especially RDP)

    This is what I kept using in Kaseya since when the system was completely blue 15 years ago! :-)

    I have seen all kind of iterations (failed Adobe Air based one, Live Connect (the old one) and the new one we have today). I always had to go back to the old VNC/RDP way.

    But now, unfortunately unless you are using old internet explorer with ActiveX support (we no longer do that due to security) the process of connection is extremely painful and un-secure (you have to download an EXE and that exe is different everytime you connect to a machine).

    Not to mention the time it takes to connect...

    Here, we blacklist execution of every executable unless they are white-listed and this method fails for us.

    I wish this executable was some kind of agent that we could install permanently instead of Active-X / Exe on demand that I could install in Program Files and white-list it but no.

    I found Guac better because it does this by simply using a Browser Canvas (so it works in an Ipad if you want) no download required all in the browser.

    I just setup a VM with it and speed-wise worked really well (RDP access with Guac rocks)

    I am still trying to find a way to access machines that sit outside the network though (like laptops outside the organization) and Guac clipboard support isn't the best but hey it's free :-)

    I have my team now testing Connectwise Control and see if it is any better (the demo I saw in youtube blows anything I have seen so far) but I can confirm this only after I see how it performs with low bandwidth..

    Basically we continue to keep looking for a better way to remote access our machines.

    and after that, I still have a problem to integrate the working solution in Kaseya.

    FYI, I had a ticket regarding File Transfer speed in Kaseya open since 2018.

    Worked a lot to help Kaseya Dev team, confirmed by them being an issue. Never fixed :-(

    With the current focus on new modules (BMS, Traverse, IT Glue etc.) I very much doubt Kaseya will have any time soon a system that works for us, hence I was hoping there could be a integration somewhere.