Kaseya Community

Kaseya V7 and ConnectWise MSP Connector

  • I posted this in the ConnectWise forums, and didn't get any feedback. Has anyone tested the ConnectWise MSP Connector with Kaseya 7? This is the connector that syncs the agent counts between ConnectWise and Kaseya. Any ideas?

  • I just upgraded to Kaseya 7 today and my integration with ConnectWise has stopped working.  I have logged a ticket with ConnectWise and am waiting on feedback from them.

  • @samct,

    Thank you for sharing. Sorry to hear about that problem. We will definitely be holding off on the Kaeya v7 upgrade until the intergration with ConnectWise and AuthAnvil 2FA are both working.

    Just curious... What version of ConnectWise are you running?


  • ,

    We are in the ConnectWise cloud - running v 2014.3 (22404)

    According to ConnectWise support v7 of Kaseya is supported, however I am still waiting on further feedback from them on how to fix the integration.

    Presumably there is an update of sorts that I will need to install on my Kaseya server.

    I will post back here once I have further information.

  • Ok - So I got some further feedback from ConnectWise.

    When I browse to the CW Web Service on my Kaseya Server


    (example URL only)

    I receive the following error:

    [HttpException (0x80004005): Could not load type 'Kaseya.SessionModule.SecureSessionModule'.]

      System.Web.Compilation.BuildManager.GetType(String typeName, Boolean throwOnError, Boolean ignoreCase) +11329664

      System.Web.Configuration.ConfigUtil.GetType(String typeName, String propertyName, ConfigurationElement configElement, XmlNode node, Boolean checkAptcaBit, Boolean ignoreCase) +64

    [ConfigurationErrorsException: Could not load type 'Kaseya.SessionModule.SecureSessionModule'.]

      System.Web.Configuration.ConfigUtil.GetType(String typeName, String propertyName, ConfigurationElement configElement, XmlNode node, Boolean checkAptcaBit, Boolean ignoreCase) +11291197

      System.Web.Configuration.Common.ModulesEntry..ctor(String name, String typeName, String propertyName, ConfigurationElement configElement) +78

      System.Web.HttpApplication.BuildIntegratedModuleCollection(List`1 moduleList) +194

      System.Web.HttpApplication.GetModuleCollection(IntPtr appContext) +1891

      System.Web.HttpApplication.RegisterEventSubscriptionsWithIIS(IntPtr appContext, HttpContext context, MethodInfo[] handlers) +166

      System.Web.HttpApplication.InitSpecial(HttpApplicationState state, MethodInfo[] handlers, IntPtr appContext, HttpContext context) +336

      System.Web.HttpApplicationFactory.GetSpecialApplicationInstance(IntPtr appContext, HttpContext context) +350

      System.Web.Hosting.PipelineRuntime.InitializeApplication(IntPtr appContext) +382

    [HttpException (0x80004005): Could not load type 'Kaseya.SessionModule.SecureSessionModule'.]

      System.Web.HttpRuntime.FirstRequestInit(HttpContext context) +11420358

      System.Web.HttpRuntime.EnsureFirstRequestInit(HttpContext context) +88

      System.Web.HttpRuntime.ProcessRequestNotificationPrivate(IIS7WorkerRequest wr, HttpContext context) +4405140

    So CW Support posted back to me with the following:


    During our testing for Kaseya 7.0, we have identified the change needed to the KaseyaWebService web config file that is on the Kaseya server.

    The change that needs to be added is the following:

    <system.webServer> <modules>

    <remove name="SecureSessionModule" />                      




    I'm assuming that they are referring to the following file on my Kaseya server:

    C:\Program Files (x86)\ConnectWise\KaseyaCwWebService\web.config

    I tried adding the additional config (see above), but this is not working.  I'm not familiar with web services and/or web.config files so presumably I didn't add the additional lines to the correct node in the .config file.

    I'm waiting for further feedback from ConnectWise and will post back here when I more information.

    I will also share the link to this page with the ConnectWise tech via the ticket I have going with them so that they can post here as well to keep everyone up to date.

  • You can't just place that snippet anywhere in the file. They'll need to provide you specifically where it goes -- just pasting it as-is will not work.

  • Thanks Ben.  I get that, however I'm still busy with ConnectWise support.

    At this point it looks like my config file is completely outdated.

    I will post back here again as soon as I have the full picture from CW support.

  • I added the code above just before my closing </configuration> tag and it worked perfectly.

  • @samct and @Brandon,

    Thanks very much for sharing what you have learned and tried so far. Much appreciated!


  • Thanks Brandon.  That worked for us too

  • Worked for me as well!


  • Does anyone know if this fix will work with R8?

  • Just tried this out on R8, and it solved my problem.  

    So glad ya'll posted this convo with ConnectWise on here!  

    I'm on Cwise v2015.2.    All was working fine until someone ran some updates to R8 few weeks ago.  Webservice has been dead since then, just noticed yesterday.