Kaseya Community

Symantec Backup Exec™ Management Plug-in 1.1 for Kaseya®

  • Good day to all!

    We are pleased to announce that the Symantec Backup Exec™ Management Plug-in 1.1 for Kaseya® is generally available. The plug-in is available here: http://www.symantec.com/business/support/index?page=content&id=tech172294

    The plug-in now supports the latest release, Backup Exec 2012.

    Please take a look and, as always, come back to the forums to tell us what you think!

  • Just installed this to our kaseya server and it looks really cool.

    Only thing im wondering about is if i can create views based on this. I'd like a view that shows me all agents with compatible version of backup exec. I opened a support ticket...

  • I'm curious what abilities you would want for this view.  Is this just for display purposes; is this a new view with new abilities or do you want a filter based on Backup Exec version for all the existing views?  Would a report suffice?

    Tom Zarrella

    Symantec Corporation

  • In order to add the agents with Symantec to be monitored through kaseya we need to run those scripts (to install plug-in, run daily summary etc.).

    If i had a view that only shows me agents with compatible versions of backup exec i can add it in Kaseya Policy Management. This way any time Symantec is setup on an agent it automatically gets the plugin and the summary scripts get scheduled automatically.

    Even if i dont use policy management its kind of tedious to jump back and forth between Backup Exec tab and Agent Procedures. I have to write down which agents are compatible to get the plugin. Then go to agent procedure and run the script. If i had a view for it i can just tell it to show me all agents that are compatible and schedule them all at once. Then schedule the daily summaries all at once.

  • Hi etabush,

    Are you talking about views as in a Kaseya Machine Filter view? Kg5RzCWTEw05


  • Yes. Sorry if i didnt explain clearly

  • Not at all, just checking. It's certainly something that could be figured out, I'm sure.

    tom@symantec_corp feel free to PM me to discuss.

  • Looking forward to workign with the latest version.

    On question, if we already have v1.0 deployed, after installing the the updated files, do we just re-run the script to install the plug-in on the managed servers?


  • Great work! I really liked the 1.0 release! I am thrilled to see support for Backup Exec 2012 now. Thanks!

    I am going to install this tonight and start playing with it. :D

  • @lwolf: If you are upgrading from v1.0 to v1.1 and you had already successfully ran the "Install Backup Exec Agent Plug-in 1.0" agent procedure against the BE (managed) servers prior to upgrade, you do NOT have to run that "Install Backup Exec Agent Plug-in 1.0" agent procedure. This specific agent procedure has to be run against only BE 12.5 or 2010 R2/R3. In case, if you have BE 2012 servers, the above mentioned agent procedure is not applicable.

    For monitoring BE 2012 servers, you have to just ensure scheduling the "Gather Backup Exec Summary Data" and "Gather Backup Exec Inventory Data". A new agent (called 'data collector', specifically for BE 2012) will be auto-pushed to BE 2012 servers as part of the "Gather..." agent procedures.


    Ramesh Bupathy (Symantec)

  • @etabush:  We'll be checking with Ray to see what he might have in mind.  We are also investigating other ways to improve the workflow that is the root of your problem.  At least we recognize your issue and are actively seeking a workflow improvement.  Stay tuned, please.

  • @symantec_corp.     thanks.

    I also wrote a list of some of my suggestions and problems.

    1. In Discovered machines. When I click the link under actions required it opens a popup. When I click ok to that popup or close it the original page goes to “null.” I’m running firefox, if that matters.

    2. It would be good if they had the live connect icon in this module. That way I can use the live connect hover-over.

    3. Was unable to open “Storage Device Space Availability” report. It gave me an error. In fact I tried a few other reports and had same issue.

    4. On the dashboard it would be good if I can drill down in “Device Space Summary” or some of the others. Only ones that allow it are active alerts summary and backup job history summary.

  • @etabush: Thank you so much for sharing your feedback!

    Regarding #1: Firefox is not a supported browser for this plug-in. Can you try with IE 8 or 9? Let us know if you face this issue in IE.

    Regarding #2: We understand your request and will add to our list. FYI - Currently, 'Live Connect' is supported but the icon & showing machine details while hovering-over is not provided. I assume, for now, you will be able to view the machine details by clicking on the machine name that is shown as a hyperlink within Backup Exec module's UI. But of course, the hover-over functionality is much useful.

    Regarding #3: I assume you will be seeing some error message in the actual report UI. Please check out the thread community.kaseya.com/.../14276.aspx (look for posts by Mr. Patrick & Symantec_corp between Apr 4th 2012 thru Apr 8th 2012). Check out the document "BEMPK_IssueWithSSRS_ReportRendering.doc" attached in that post and see if you are seeing the same error message.

    If you are getting error that is shown below, you may still follow the resolution step mentioned in the "BEMPK_IssueWithSSRS_ReportRendering.doc"  document.

    Unable to display report. Please try after some time.
    Please check log for more detail.

    • The item '/BackupExec/rptBE_StorageDeviceSpaceSummary' cannot be found. (rsItemNotFound)

    If the steps mentioned in the document did not resolve your report loading issue, let us know with a screenshot or error message that you are seeing.

    Regarding #4: This functionality is in our feature list. Your vote is counted!


    Ramesh Bupathy | Symantec Corporation



    [edited by: symantec_corp at 7:20 AM (GMT -7) on 6-27-2012] correction
  • HI

    Just installed the BE 1.1 plugin on K2. Nice. Finally a way to poll more info from BE via Kaseya. Long past due. Thanks.

    Couple of things encountered tho:

    1. Test attempts to install on a 2008R2 Standard Edition running BE 2010 R3 (Service Pack 2) , I get this from the Kaseya agent log file:

    FAILED in processing THEN step 6, Execute File, with error Command Message Timed Out, %windir%\system32\wscript.exe "C:\Program Files (x86)\Kaseya\MATxxxxxxxxxxxxxxxxx\BEMPKDataCollector\BEMPKUtility\BEUtility.vbs" -op:Install.

    Multiple attempts fail. Installs fine on other servers. Any ideas?

    2. Try to run reports, I get this:

    Unable to display report. Please try after some time.

    Please check log for more detail.

    The request failed with HTTP status 401: Unauthorized.


    [edited by: Shickey at 8:36 AM (GMT -7) on 6-28-2012] update tags
  • @symantec_corp

    This is the error im getting when opening reports (i tried multiple browsers)

    Unable to display report. Please try after some time.

    Please check log for more detail.

    The request failed with HTTP status 401: Unauthorized.