Kaseya Community

AVG9 Optimization Scan

  • I have seen a few posts about an Optimization Scan dialog window displaying after AVG9 is installed. I have also seen a few posts about an computers slowing down after AVG9 is installed - and someone responded that it was likely due to the optimizations can running in the background.

    We have about 600 agents running KES/AVG8.5, but have only install AVG9 on a handful of machines so far. I have only personally seen the Optimization Scan dialog window on one computer during our inhouse testing, so I am not very familiar with it.

    Question... if I over-install AVG9 on an existign agent that is already running KES/AVG8.5, when does the Optimization Scan run?

    Does it run right after the install - before a reboot?

    Does it run after the next reboot? If I did the install at night, would it run at that time, after the reboot, before a user logon the next morning?

    OR does it run after the next reboot and the subsequent user logon?

    Any information that people have to share/offer would be aprpeciated.

    Thanks in advance.

    Lloyd

    Legacy Forum Name: AVG9 Optimization Scan,
    Legacy Posted By Username: lwolf
  • I have installed on several systems now and havent seen any optimisation scans at all.

    Do they still happen, or have K managed to get this 'feature' removed?

    Legacy Forum Name: KES,
    Legacy Posted By Username: PeterS
  • Granted, we have a very small test sample. Machines that had previous AV removed, with fresh AVG v9 gave us problems with performance.

    Machines with AVG v8.0 or v8.5 that we installed over, were fine. No issues.

    Legacy Forum Name: KES,
    Legacy Posted By Username: Andrew Carey
  • I have seen it today on a laptop I upgraded from avg8.5 to avg9 in KES 2.1. So it is not corrected yet. In every case that I have seen it has shown up after the reboot. It is a pop-up message that asks if you want to optimize for scanning or not. I click X to get by it.

    Legacy Forum Name: KES,
    Legacy Posted By Username: jasonp
  • Installed on 16 desktops yesterday afternoon.

    Client is FURIOUS that almost all workstations are DEAD SLOW today.

    Here we go again.

    Legacy Forum Name: KES,
    Legacy Posted By Username: Interprom
  • What Installation Options did you use? While I've only done a few AVG9 installs, I tend to be conservative and skip a lot of the fluff (e.g. I do NOT install Office add-in, email scanner & Firewall). On some older PCs I found that the Web-Shield component caused serious browser slowness issues for me, so sometimes I skip that one too. It might be wise to start with a barebones profile, then slowly add more options (after testing each).

    Interprom
    Installed on 16 desktops yesterday afternoon.

    Client is FURIOUS that almost all workstations are DEAD SLOW today.

    Here we go again.


    Legacy Forum Name: KES,
    Legacy Posted By Username: ReedMikel
  • jasonp
    I have seen it today on a laptop I upgraded from avg8.5 to avg9 in KES 2.1. So it is not corrected yet. In every case that I have seen it has shown up after the reboot. It is a pop-up message that asks if you want to optimize for scanning or not. I click X to get by it.


    1) Can anyone explain to me what purpose the AVG Optimization Scan serves? Is it a one-time pain for long-term gain?

    2) if it is not needed for a gain, but it does not start until user logon, has anyone found s registry key/setting thst we could include in a post-install script to disable the Optimization Scan and/or the popup window prompt?

    Legacy Forum Name: KES,
    Legacy Posted By Username: lwolf
  • This might help: http://forums.avg.com/us-en/avg-free-forum?sec=thread&act=show&id=37299

    Legacy Forum Name: KES,
    Legacy Posted By Username: Coldfirex
  • Can one prevent the optimization scan from ever running? I do not want my users' PCs brought to a crawl for hours while a so-called optimization scan occurs.

    If it's a unique .exe or .dll, I suppose we could use Application Blocker on it...

    Legacy Forum Name: KES,
    Legacy Posted By Username: ReedMikel
  • Its an AVG thing. They have since fixed their code and are running it through their testing and plan to release in about a week.

    The release will come through the normal AVG update process

    Jeff

    Legacy Forum Name: KES,
    Legacy Posted By Username: Jeff.Keyes
  • So, can anyone tell me... when does the AVG 9 Optimization Scan run?

    Does it run right after the install completes - before a reboot?

    Does it run after the next reboot? For example, if I did the install at night, would it run at that time, after the reboot, before a user logon the next morning?

    OR does it run after the next reboot and the subsequent user logon?

    Any information that people have to share/offer would be appreciated.

    Legacy Forum Name: KES,
    Legacy Posted By Username: lwolf
  • Thanks for the update Jeff. I guess that means they didn't test their product? Or, does the Optimization scan slowness issue only affect Kaseya users (maybe because of the API)?

    Jeff.Keyes
    Its an AVG thing. They have since fixed their code and are running it through their testing and plan to release in about a week.

    The release will come through the normal AVG update process

    Jeff


    Legacy Forum Name: KES,
    Legacy Posted By Username: ReedMikel
  • AVG has gotten a lot of feedback (negative) from ALL of their users on the optimization scan.

    Essentially it isn't needed - the purpose of the process is to build a cache that it uses for all scanning (resident shield, email scanning, web scanning, etc). The cache is automatically build whenever ANY full machine / computer scan is run (including via the API). Until then, all of the scanning methods will be slower than they could be with the cache.

    Jeff

    Legacy Forum Name: KES,
    Legacy Posted By Username: Jeff.Keyes
  • I guess AVG never even ran a scan on one of their own machines. Amazing Sad

    Legacy Forum Name: KES,
    Legacy Posted By Username: ReedMikel
  • Jeff - I just installed AVG9 (over 8.5) and after it restarted it displayed a popup asking about the Optimization Scan. AVGUI.exe reports AVG version is 9.0.730. My VSA reports "Current Installer Version: 9.0.730a1834".

    I assume this issue has not been fixed? Or, my KServer did not auto-update for some reason?

    Jeff.Keyes
    Its an AVG thing. They have since fixed their code and are running it through their testing and plan to release in about a week.

    The release will come through the normal AVG update process

    Jeff


    Legacy Forum Name: KES,
    Legacy Posted By Username: ReedMikel