Kaseya Community

Install Log File Link

  • The install log file link works around 15% of the time for me, it seems that most of the time when an install shows failed in the KES console it does not have an install log so the link is useless. Although when the install shows as "AVG Removed by User" this is 90% of the time also a failed install that has a log file but no link to it.

    It would be nice to get that same link added to the AVG Removed by User status, or even better would be to fix the way the KES console reports the removed and failed installs.

    Legacy Forum Name: Install Log File Link,
    Legacy Posted By Username: cnwicsurrett
  • Call me stupid... but where is the link for the install log file? I have not sseen it.

    It would be very handy to be able to display easily, instead of having the do an FTP remote control to the machine to view the log file.

    Lloyd

    Legacy Forum Name: KES,
    Legacy Posted By Username: lwolf
  • I have seen where most of the time when KES fails to install, there is a link to the report for it under the Install\Remove section. If you click it almost always tells me that the file does not exist (or something). I actually opened a ticket for it this week. no repsonse yet though.

    Legacy Forum Name: KES,
    Legacy Posted By Username: Coldfirex
  • I've never noticed any link to an install log under the Kaseya install page, however the actual install log is located in the KESInstall directory beneath whatever directory you have set as temporary.

    The log file starts to get created only after the package is pushed down, unpacked and the actual install routine is started.

    Legacy Forum Name: KES,
    Legacy Posted By Username: doug.jenkins@ispire.ca
  • doug.jenkins@ispire.ca

    The log file starts to get created only after the package is pushed down, unpacked and the actual install routine is started.


    Exactly, Kaseya shows KES failed to install when it can't run the install routine(which intern there is no log file) and shows AVG Removed By User, when the install routine starts but does not complete (most of the time there is a log file but no link to the log file) I believe the log file link only shows up for people with 2.1 beta installed.

    Legacy Forum Name: KES,
    Legacy Posted By Username: cnwicsurrett
  • I am running KES 2.1 Beta. I don't see any links for the install log files. Where should it be?

    Lloyd

    Legacy Forum Name: KES,
    Legacy Posted By Username: lwolf
  • Capture.JPG
    On the install status, for example this is an agent that failed to install because it couldn't find the local source to install KES, thus no log file... yet I get a link to a page that says "File not currently available on the server."

    Legacy Forum Name: KES,
    Legacy Posted By Username: cnwicsurrett
  • we fixed up this log file logic a bit more - there are some common cases where the installer fails that we know we won't get a log file...thus we took out the link.

    Legacy Forum Name: KES,
    Legacy Posted By Username: Jeff.Keyes
  • Jeff,

    Just wondering... What would you think about linking the log file even on succesful installs?

    Lloyd

    Legacy Forum Name: KES,
    Legacy Posted By Username: lwolf
  • Interesting idea...not likely to make the 2.1 cut at this point. I'll add that for the future

    Legacy Forum Name: KES,
    Legacy Posted By Username: Jeff.Keyes
  • Jeff,

    Thanks. Adding in the future sounds like something that might be good. As I have been deploying KES over the past 8 weeks or so, working with Beta's, etc., I have often been FTPing to machines to review the AVG install log file. It would be nice to have easily available.

    In the meantime, I think I am going to update my KES post-installscript to grab the AVG install log. That won't be hard for me to do, and address the opportunity right away.

    Lloyd

    Legacy Forum Name: KES,
    Legacy Posted By Username: lwolf