Kaseya Community

Error on Install Page

  • I am getting the following error on the install page. Anyone have any ideas?

    KES 2.0 encountered an error while processing this page.
    Please contact Kaseya Support if the problem persists.

    Exception:


    System.NullReferenceException: Object reference not set to an instance of an object. at Kaseya.Service.KES.Impl.KESLicenseService.TotalLicensesPurchased() in c:\BuildArea\KES15Nightly\Kaseya.Service.KES\Impl\KESLicenseService.cs:line 302 at KESLicenseServiceProxy093448f03c6b442499cf8997b74e7215.InvocationTotalLicensesPurchased_5.InvokeMethodOnTarget() at Castle.DynamicProxy.AbstractInvocation.Proceed() at Kaseya.Service.NHibernateServiceCallInterceptor.Intercept(IInvocation invocation) in c:\BuildArea\KES15Nightly\Kaseya.Service\NHibernateServiceCallInterceptor.cs:line 63 at Castle.DynamicProxy.AbstractInvocation.Proceed() at KESLicenseServiceProxy093448f03c6b442499cf8997b74e7215.TotalLicensesPurchased() at ManageAVClient.Page_PreRender(Object sender, EventArgs evt) in e:\Kaseya\WebPages\AntivirusTab\ManageAVClient.aspx.cs:line 217 at System.Web.Util.CalliHelper.EventArgFunctionCaller(IntPtr fp, Object o, Object t, EventArgs e) at System.Web.Util.CalliEventHandlerDelegateProxy.Callback(Object sender, EventArgs e) at System.Web.UI.Control.OnPreRender(EventArgs e) at System.Web.UI.Adapters.ControlAdapter.OnPreRender(EventArgs e) at System.Web.UI.Control.PreRenderRecursiveInternal() at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

    Legacy Forum Name: Error on Install Page,
    Legacy Posted By Username: mmoore
  • Try re-applying the schema.

    Legacy Forum Name: KES,
    Legacy Posted By Username: boudj
  • Thanks, and how do I do that?

    Legacy Forum Name: KES,
    Legacy Posted By Username: mmoore
  • I found it. It did not work.

    Legacy Forum Name: KES,
    Legacy Posted By Username: mmoore
  • Contact support... I do recall some users having a licensing issue (related to KES) that the fixed. This might be the case.

    Legacy Forum Name: KES,
    Legacy Posted By Username: boudj
  • Thanks. I just opened a ticket. Hopefully the response will be better than normal. Otherwise it could be weeks.

    Legacy Forum Name: KES,
    Legacy Posted By Username: mmoore
  • Let me know what you hear, I'm having the exact same issue.

    Legacy Forum Name: KES,
    Legacy Posted By Username: ckaye99
  • ckaye99
    Let me know what you hear, I'm having the exact same issue.


    Support told me to run the latest patches and that solved the issue.

    We would like to perform the following steps to over come this issue.

    1) click the Get Latest Hotfix button under System > Server Management > Configure
    2) when it completes checking, click on the Reapply Schema link under System > Server Management > Configure (some hotfixes require DB Schema updates to take effect)
    3) when Reapply Schema completes, hover over the button again to check the hotfix level you are on then click Get Latest Hotfix again. If the hotfix level changes again repeat these steps until it stays at the same level (in some cases more than one update is required to get to the latest level)

    Legacy Forum Name: KES,
    Legacy Posted By Username: mmoore