Kaseya Community

KES AVG 2012 Upgrade from AVG 9 fails on Windows 7 64-bit machines

This question is not answered

Please bear with me on this, because I just started working with Kaseya last Thursday, and so far, I think it's an amazing product.

As for the issue....

I have noticed that while attempting to use the Kaseya agent to upgrade AVG9 to AVG 2012 on Windows 7 64-bit machines, it fails consistently.  There has been no way, that I could tell, to force it to complete properly other than going into the "kes" folder and double-clicking the installation file to install it.  HOWEVER, this has only worked for 1 of 6 machines, because of the License Key issue.  I have reviewed all of our other AVG 2012 installations and attempted to use the License number seen on those installations to install on these machines, but it comes back is "incomplete license" and will not move forward.

My trouble is, the upgrade utility successfully uninstalled AVG9, but fails installing 2012, which is horrible, considering that those users in question are now unprotected.

I am just hoping someone has a magic answer to resolving this issue, because I am at a loss.  I have tried running "AVG Removal Tools" and the "delrepwv_en.exe" script which was supposed to correct registry entries which cause this issue, both attempts were unsuccessful in getting the Agent to install AVG 2012 properly.

If anyone out there can help me, I would GREATLY appreciate it.

I thank you in advance, for whoever responds.

All Replies
  • Eric,

    Has UAC been disabled?  I know that's been an issue and Kaseya recommends disabling that in the read me for KES 2.3.  I've also had upgrades that failed and running a regular install afterward completed successfully.

    The license you can see is missing the last 4 (I think) characters of the complete license.  I believe that's what I've seen in the past when comparing the license from inside the client to the actual license key.  I assume AVG did this so you couldn't just look at one system can copy down the license for use on another.

    -Shannon

  • Yes, it has been disabled, I'm sorry, I should have mentioned that.  I have also went back and attempted normal installs after the removal of AVG 9 had completed successfully, and they are still failing.  The "kes" folder doesn't even download the installation file any longer, which really confuses me.  I have attempted forcing an agent update as well, which runs successfully, however, it doesn't resolve my issue.

    I understand if that's the cause behind the Licenses, however, where would I be able to find the legitimate key in order to properly install?  Is that something I would have to contact AVG for?  Or should I be able to find that in the Kaseya system?

    Again, I apologize for my inexperience, and perhaps ignorance, but I have just recently started working with this system.

  • No worries, had to ask.  And we were all new to Kaseya at some point.

    Not sure why it wouldn't be downloading the installation files though.  Are you going direct to the endpoint or using a patching share?

    You should be able to get the key from either your Kaseya rep or support.  We've been given that in the past to troubleshoot these type of issues.  Then you should be able to manually install AVG 2012 and use the connect client feature to take over management of the endpoint.

  • I am actually unsure what you mean there.  If you are asking if I am deploying installation through Kaseya Security Installations portion on the VSA, then yes, I am.  If you are asking if I have logged into the machine in question and attempted installs from there, I have, however, it was only successful once.  Once I have tried pushing it back out to the machines it wouldn't work on, the kes folder loses the installation file and won't re-download it.  It was suggested to me to remove the kes folder and attempt to push it out again, and now the kes folder doesn't come back either.

    I just don't know what I am doing wrong here.

    I will have my boss try to get in contact with AVG for the key in order to download and install the standalone version, then I should at least be able to get it to synchronize with Kaseya by using the "Connect" feature.

    But if you, or anyone reading this, has any more ideas, I am willing to give it a shot.

    Thanks again.

  • Within the patch management in Kaseya you can configure a patching share for distribution of patches.  KES uses this when configured.  I was just curious in which method you were trying to deploy from.  If your Install Source in KES is KServer, then you are sending the installation package directly from your KServer to the endpoint for installation.  If it has a UNC path, then a patching share has been configured and that's where AVG would be deployed from.

    I've seen weird issues be cleared up by either restarting the agent service or rebooting the endpoint.   Sometimes I think the agent just gets confused and some of its services stop working while others continue on just fine.

    You'll probably need to go back to Kaseya for the license key, that's who we've always gotten it from, as AVG probably won't have a record of anything to give to you.

    You could attempt to install a trial license on the endpoint to see if there is an issue with the AVG installer on the system.  I've also done that in the past and found the underlying issue to be resolved and then deployed KES after the fact.

  • I see now, it is downloading from the internet.  What are your suggestions on that?

    I have tried rebooting the client machine, as well as re-installing the agent, neither of which have resolved the issue.

    And thank you, I will be sure to ask him to get in touch with Kaseya rather than AVG, that could have been a decent amount of wasted time.

    Good suggestion on the trial license, maybe that's what I should do, and then try to connect it back to Kaseya.  Or will it not work that way?

  • Give it a shot.  I'm not sure as I haven't tried that with KES 2.3.  Worst case you get something on the endpoint to protect it until you can get help with your issue.  And maybe it'll throw an error during the install that will lead you to the root cause of the problem.

    As far as deploying from your KServer or a file share, really depends on what you have to work with.  If it's just a couple systems and you don't have a server or workstation to park a share on, then deploying from your server is fine.  Just remember it has to push the 120+MB installation file up to each system so spread them apart unless you and your client has the bandwidth.  The file share is good if you have several clients to deploy as you only have to upload the installers once and each endpoint go to the share to install from.  Not sure it's still the case, but I know KES 2.3 was uploading 4 different installers (totally ~600MB) to the share so it can take quite a while before you actually see anything happen on your endpoint that you are trying to deploy AVG to.  After that it simply verifies the installer is the correct version and then kicks off the install on the endpoint so it can save a lot of time and bandwidth.

    Same goes for the Microsoft patching.

    Kaseya 6.3 will introduce LAN share which will replace this and provides the same functionality, but that's another discussion.

  • Just as an update, complete removal, rebooting twice, and pushing it out again seemed to get them to install correctly.  But that should not be the solution.  Still having a few troubles, but I will make it work.  Just hoping someone will find the easy fix for this.