Kaseya Community

KES Install "Failed...(UNKNOWN FAILURE)"

  • I keep getting this message whenever I try to deploy KES to one machine at one of our clients.  No log file ever gets created in the "temp\kes" directory on the hard drive, so I have no idea what the problem could be.  I've run CHKDSK, Dial-a-fix, many different malware / rootkit scanners, Windows SFC scan, and hardware diagnostics on the computer, all of which find no problems.  I even tried installing AVG Free Edition 2011 to see if that would get stuck anywhere and give a useful error message, but it installed fine without any issues at all.  

    I also reinstalled the network driver on the computer, and ran the windows stackfix commands, but no luck.

    Has anyone ever had this problem before?

     

    Note: The PC is running Windows XP Professional with all the latest updates and SP3.

  • what is your installation source? LAN ?  try to install from Kserver

  • Same problem today. I had a similar problem a few months agao, tech support sent me this. I used this again and its what fixed it for me:

    Substitute the new version for the .exe listed in the support response.

    download.avg.com/.../avg_ipw_stf_all_90_901a3689.exe

    download.avg.com/.../avg_msw_stf_all_90_901a3689.exe

    ---From Kaseya tech Support -----

    Go to your kaseya server and go to location:

    \\kaseya\webpages\managefiles\vsahiddenfiles\av

    delete the following files:

    avgInstall.exe

    avgExchangeInstall.exe

    Copy the below files to the \\kaseya\webpages\managefiles\vsahiddenfiles\av

    1. AVG 9 Exchange installers

    download.avg.com/.../avg_msw_stf_all_90_894a3479.exe

    after this file downloads to your kaseya server, please rename to avgExchangeInstall.exe

    2. AVG 9 Installer for non exchange machines

    download.avg.com/.../avg_ipw_stf_all_90_894a3479.exe

    after this file downloads to your kaseya server, please rename to avgInstall.exe

    We've seen issues in the past where the installation will get corrupted, and manually updating the installers resolves the issue.

    Regards,

    *****

    Kaseya Support

  • Thanks for the reply, but I don't think this is the problem.  We have hundreds of clients with thousands of workstations, and this is just one computer at one client having the problem.  AVG installs fine for everybody else, so the issue can't possibly be server-side.

  • ah, ok, my problem was every install failed this way.

    have you tried using AVG's removal tool? It can be downloaded from AVG.

    I've used that in the past on problem installs, you may need to run it several times and again after a reboot for it to remove all traces.

    Good luck...

    Jeff



    [edited by: JMF at 6:08 AM (GMT -7) on 6-28-2011] spell check
  • I was finally able to resolve the problem.  I forced an agent update (Agent -> Update Agent, and check "force update"), then from the Security -> Install/remove page, I checked the "Install from KServer" box, and AVG installed without issue.  

  • I tried that but it didnt help still same problem  "Install Failed (Unknown failure)"

    I tried AVG removal tool and manually remove and file related to AVG

  • when you run the install, can you monitor a machine? and see if the whole AVG installer makes it to the machine? i know we had an issue that sometimes the installer got cut off. it's supposed to be approx 213MB but in some cases it was only 50mb and the the install started to run (and failed).  

  • I see two AVGinstaller executable running.. they just sit there forever.

  • FAILED at [Current time] (Failed while trying to copy installation files)

    I removed the KES folder and attempted to re install i get the above error