Kaseya Community

AVG 9 - released to KES when?

  • Yikes, I consider this to be a pretty big unexpected problem.

    I had an existing Agent with KES/AVG v8.5 installed on a test computer at my house - just in a WORKGROUP, no domain. A few days ago, I had upgraded it (via Kaseya) to v9. When I checked, I found that it presently had the firewall enabled.

    I disabled the firewall, confirmed it was disabled, then started a KES reinstall/overinstall, and went to bed. This morning, when I checked it, I see the log files that show the KES deployment successful, and I also see the Windows Firewall enabled.

    Part of me says that having the Firewall enabled is maybe a good thing. But my initial gut reaction is that it will cause problems - or at least introduce other unintended consequences that I will have to deal with.

    Perhaps I could write a pre-script to record the firewall status prior to the install, then a post-script to reset it to the original value after the install, if the value has changed.

    I will definately have to dedicate some time to this soon. Rats.

    Legacy Forum Name: KES,
    Legacy Posted By Username: lwolf
  • Thanks for confirming this. My concern was a bit understated. I think this will block remote control for PCs and lots of other services like dhcp or even inbound kaseya, offsite backup, web, smtp for servers. I can confirm the inbound kaseya and offsite backup because I installed it on the kserver. It wasn't pretty.

    Legacy Forum Name: KES,
    Legacy Posted By Username: runnetworks
  • I've not seen that here. Can someone check the install log of that affected machine and find out if this is a Kaseya bug or an AVG bug? (In the install log, it will show if we set the switches correctly to not install the firewall component).

    On that end, we do have the Kaseya agent white listed...

    Jeff

    Legacy Forum Name: KES,
    Legacy Posted By Username: Jeff.Keyes
  • Jeff, it's not the AVG firewall that is enabled. Does AVG manage the windows firewall?

    Legacy Forum Name: KES,
    Legacy Posted By Username: runnetworks
  • I noticed this as well on 2 Win2003 servers a little while ago (pre AVG 9) when reinstalling KES - the windows firewall was turned on after the reboot. I thought I was going mad, turned it off and left it at that as it was only on 2 servers (all workstations/laptops etc that I installed on were unaffected).

    Legacy Forum Name: KES,
    Legacy Posted By Username: richardprice
  • And it was on a client's Oracle server... freaked them (and me) out completely! I swore to them that I'd never seen our management tool's AV enable the firewall, and they (seem to) have believed me, since I was being honest at the time.

    But hearing this report from y'all makes me worry!

    -Another Matt

    Legacy Forum Name: KES,
    Legacy Posted By Username: Matthew Bartels
  • I upgraded from 8.5 to 9 kes and no email. Thw windows firewall got enabled.

    Legacy Forum Name: KES,
    Legacy Posted By Username: gdoubinin
  • I've had this happen on a few XP machines in a workgroup setting with new installs of KES/AVG 8.5, where the Windows firewall got turned on.

    Legacy Forum Name: KES,
    Legacy Posted By Username: rkniffin
  • A few of our users are getting the pop-ups asking to upgrade to 9.0 also. I have notified them to hit the UPGRADE LATER button for now. Is there anyway to stop this pop-up???

    Legacy Forum Name: KES,
    Legacy Posted By Username: dapopa9
  • Yes we are also getting this now on our clients. Hope someone has an answer to this.

    dapopa9
    A few of our users are getting the pop-ups asking to upgrade to 9.0 also. I have notified them to hit the UPGRADE LATER button for now. Is there anyway to stop this pop-up???


    Legacy Forum Name: KES,
    Legacy Posted By Username: webitservices
  • Some of my clients are getting the upgrade popup too Sad I left a vmail for Jeff. He emailed back that we was not happy with AVG for this oversight... Jeff - can we use Application Blocker to stop whatever process is displaying that upgrade message?

    Legacy Forum Name: KES,
    Legacy Posted By Username: ReedMikel
  • we have pushed out the update to about 100 machines. It seems that we have 3 groups that are still saying at Version 8.5... The installed dates on Dec 1/09 and Dec 02/09. All the machines in the affected group says 8.5 or in other groups they are successful and upgraded to 9.0. Has anyone seen this problem?

    Legacy Forum Name: KES,
    Legacy Posted By Username: gdoubinin
  • Some updates

    Firsts of all, I'm truly sorry for the pop ups that some end users are seeing. We've had LOTS of discussions with AVG regarding how bad it is to EVER pop up UI and somehow a pop up notifying end users to upgrade to AVG9 slipped into the Kaseya marked SKU. I'm meeting with the product management group at AVG to get this fixed ASAP.

    In addition to that, there is a new scan optimization pop up that we are also working on hiding / disabling.

    Anyways...all of this is just unacceptable. I'm going to drive the points home (again) about the critical nature of not doing this kind of "home user" behavior toward business users - especially business users who are managed workstations.


    Another point - we've uncovered a bug in the API wherein after upgrading AVG9 over AVG8.5, the API misreports the version number of the workstations at 8.5 when in fact it has been upgraded. After rebooting the machine, the correct version numbers are shown. We are working on a hotfix for that as well.

    To continue the drama...we found that a switch to hide the system tray no longer works (not sure what build in AVG9 it stopped working...but I know we tested this in earlier builds). We are releasing a hotfix to just workaround this problem.

    Its hard when working with a vendor and keeping up with the changes. We are trying our best to integrate in such a way as to minimize these kinds of things. In AVG's defense, we are all fighting a war against the malware vendors and this requires constant updating - and that alone is a big battle in itself.

    As always, I"m sure I'll continue to get the email flood. I'll try to keep everyone updated with the ongoings.


    Jeff

    Legacy Forum Name: KES,
    Legacy Posted By Username: Jeff.Keyes
  • Jeff - can we use Application Blocker to stop whatever process is displaying that upgrade message?

    Legacy Forum Name: KES,
    Legacy Posted By Username: ReedMikel
  • Thanks for your help Jeff. We all wish we were not dealing with ANY issues related to AVG v9 release. But it is good to know that you are on the job, and working hard to address the issues, and are keeping us informed, etc.

    Thanks for your help!

    Legacy Forum Name: KES,
    Legacy Posted By Username: lwolf