Kaseya Community

"Backup Failed Unexpectedly"

  • Brand new Windows 2008 Small Business Server, just installed a few hours back. Installed BU-DR (9.7). Set up the target and started an initial backup. Almost immediately (within about 30 seconds) I get a log entry showing "Backup Failed Unexpectedly".

    What the heck does that mean? I'm never EXPECTING a failure, so aren't ALL failures "unexpected"?

    How do we track down where this "unexpected" failure is and what's causing it?

    I have now seen this problem on 3 different systems (two XP workstations, one 2008 SBS server) since upgrading from BU-DR 9.5 to 9.7 On the workstations, I'll consistently get a "backup failed unexpectedly" error, followed by a perfectly complete backup and verify cycle.

    On this 2008 install, things I've already verified:

    1. The credentials are set properly and have passed the credential test.
    2. The backup target setting is valid (shows space free, and gets as far as creating a readme.txt).
    3. Happens whether VSS is on or off.


    -Dan

    Legacy Forum Name: "Backup Failed Unexpectedly",
    Legacy Posted By Username: DNeuwir
  • This is happening on all of my machines starting today. I am guessing kaseya's updates broke this. Hopefully they will fix this fast.

    Legacy Forum Name: BU-DR,
    Legacy Posted By Username: ebieber@engineered-solutions.com
  • Ditto, getting a whole slew of these today.

    Legacy Forum Name: BU-DR,
    Legacy Posted By Username: benny@geeksaknockin.com
  • This is the reply I got from Kaseya Support:

    Please make sure to get the latest hotfixes by visiting the System > Server Management > Configure page and click the "Get Latest Hotfix" button. Then, visit the System > Server Management > License Manager page and rollover the BUDR entry. You want to make sure that you are at a BUDR 3.1 Hotfix level at or past level 662.Yesterday a hotfix is released to address this issue ‘Backup failed unexpectedly’.

    Legacy Forum Name: BU-DR,
    Legacy Posted By Username: KevinTW
  • Here's the reply I received from a ticket I reported yesterday morning on this issue:

    FYI - As per Kaseya Development:

    --

    A hotfix sent out on Friday causes this to happen for full backups. The error can be ignored, and the problem that caused this has been hotfixed earlier today.

    --


    Regards,
    Kaseya Support


    I reapplied hotfixes and the update took me hotfix level 2605, but I am still having this problem. It seems the hotfix for the hotfix did not work properly.

    Legacy Forum Name: BU-DR,
    Legacy Posted By Username: pcmnetmanage
  • Did you use the 'reapply schema' option after getting the hotfix? It seemed to work for us. No more 'backup failed unexpectedly'. Smile

    Legacy Forum Name: BU-DR,
    Legacy Posted By Username: KevinTW
  • KevinTW
    Did you use the 'reapply schema' option after getting the hotfix? It seemed to work for us. No more 'backup failed unexpectedly'. Smile


    Yes, that is what I ultimately did to correct this issue.

    Thanks

    Legacy Forum Name: BU-DR,
    Legacy Posted By Username: pcmnetmanage