Kaseya Community

Slow File Transfers (causing slow backups or failures)

  • So I've been battling some slow and failing backups at various customer sites. Large data servers either taking FOREVER to backup or flat out failing (often on the fulls).

    After MUCH troubleshooting and researching I believe I've found the cause:

    http://blogs.technet.com/askperf/archive/2007/05/08/slow-large-file-copy-issues.aspx

    Basically the windows copy command trys to buffer the file and it can basically make your system run out of reasources and the copy process gets slow.

    I've reproduced this on EVERY server (2003 at least) I've tried it on. I can take a large file like 10-50gigs for instance and copy it from it's own C: drive to it's own D: drive. The file starts going saying ~5-10minutes but after a few minutes of coping it will suddenly slow way down as you watch the time start counting up to like ~100minutes. Same thing coping over a network connection. It's MUCH more noticable using 1000BT then 100BT.

    Now the one variable here is that most servers will still copy the file but slower. I have a handful that it gets so slow it almost comes to a standstill. Those are the ones that are causing my backups to fail. Furthermore they didn't start out that way. I have an Intel Storage server for instance with a 2.4G quadcore and 2G of ram, raid5 data drive that worked fine for a few months then seemingly all of a sudden got bad to the point that coping almost anything to it will causing this problem to surface. Intel support hasn't been much help. I have another completely different box that did this (first time I came across this issue, thinking maybe the array controler was bad). I put in new hard drives and recreated the array. It's been running ok for me since then.

    Anyway I wanted to see if anyone has battled similar issues. I don't think we'll see Acronis/Kaseya change from using the windows copy command to something else so I don't know what a good work around for this might be.

    Legacy Forum Name: Slow File Transfers (causing slow backups or failures),
    Legacy Posted By Username: bent
  • I am having the same issue it appears. I have a client with two servers with approx equal amounts of data. One server takes just over 1 hour to backup and one takes as much as 9 hours. This server used to not take that long. It also freezes up the server to the point of unresponsiveness as well. Not cool that we have to manually power down our Domain Controller multiple times. It does appear to be happening on Domain Controllers across our clients if that is a pattern.

    Legacy Forum Name: BU-DR,
    Legacy Posted By Username: stephen.mccollum