Kaseya Community

Grey Screen of Death

  • I have a few servers that become completely unresponsive during scheduled backups. Mouse still moves around on the console, but CNTL-ALT-DELETE removes the CNTL-ALT-DELETE screen, but then nothing else....no login prompt. A hard-reboot is the only option to fix them.

    I found a MS hotfix for VSS that sounded like the trick....but didn't do anything.

    Any input is appreciated.

    Legacy Forum Name: Grey Screen of Death,
    Legacy Posted By Username: Erik
  • We actually had something extremely similar to this yesterday. The server was responding and working just fine, the agent was checking in and all. However the machine was not sending status updates (aside from usual check-in) to our console. No errors, no alerts nothing.

    When we remoted in, a grey screen, mouse moved, nothing else. Sending the Cntrl+Alt+Del command didn't bring up the logon screen either. We are still investigating, but we found that a drive had "failed" and was no longer functioning within the RAID5 array. We disconnected the drive and hard-rebooted the machine so the client didn't have any downtime. Right now the array is running in a degraded state because we want to activate the hot-swap over the weekend so they can stay operational.

    Until we get the actual drive back to our lab we aren't sure if the drive actually failed or if BU/DR (Acronis) doesn't work well with RAID5 arrays.

    However, now that the drive has been disconnected from the array, everything is working just fine. So maybe that will help you with a starting point.

    Legacy Forum Name: BU-DR,
    Legacy Posted By Username: CeruleanBlue
  • Yup. I had thought of that. The drives in one of these servers was heavily frag'd. We ran scandisk and defrag'd the drive multiple times but the problem still seems to appear.

    Frustrating, to say the least.

    Legacy Forum Name: BU-DR,
    Legacy Posted By Username: Erik
  • Hummmmm... we've had a similar thing happen recently and finally isolated it to the AV. What AV are you using on the problematic server?

    Legacy Forum Name: BU-DR,
    Legacy Posted By Username: boudj
  • We noticed this problem on a few HP Servers in combination with TrendMicro and SBS 2003, disabled realtime scanning solved the problem (creating a new one....)

    Albert Smit
    LANtrust

    Legacy Forum Name: BU-DR,
    Legacy Posted By Username: lantrust
  • What we have seen is that with large volumes and older equipment, the installed AV product was getting in the way and creating a long delay or preventing the mount all together, thus the hang or failure. Outside of stopping the AV service or reconfiguring the AV product, there is no other work around. We are speaking with Acronis for other solutions.

    Legacy Forum Name: BU-DR,
    Legacy Posted By Username: kaseya
  • That, at least, gives me something to try....and presents another problem.

    We use the Kaseya EndPoint Security on these servers.

    Does anyone know of a way to schedule the Kaseya EndPoint Security (AVG) services to stop/start? I know the option to stop them manually is disabled....so how can this be scheduled through Kaseya?

    Legacy Forum Name: BU-DR,
    Legacy Posted By Username: Erik
  • We used to see this alot when VSS was enabled in our BUDR backups. We have been forced to disable VSS in our backups until Kaseya can get Acronis 9.5 Echo integrated (supposedly the VSS issue is fixed in this release per our Kaseya rep),

    Legacy Forum Name: BU-DR,
    Legacy Posted By Username: Coldfirex
  • Do you use Backup Exec on the server? We had similar issues with grey screens on a few servers and the answer was to install BUDR first, then BU Exec due to some incompatibilities.

    This seems to have worked. Unfortunately, since we are always adding BUDR after the server is installed at a client, we need to then uninstall BU Exec, install BUDR then reinstall BU Exec and set everything back up. Lots of time, but it seems to have fixed this problem.

    Legacy Forum Name: BU-DR,
    Legacy Posted By Username: mmatosky
  • We have been having this problem for over a year on many servers and we wore out several threads with this problem on the old forum. I have found that unchecking VSS in Kaseya fixed it in 99% of the cases. It is a known problem and I have not found that it is related to AV or machinery.

    Most of our servers are SBS, so there is a lot of VSSery that needs to occur when the backup starts. The way I understand it is that the Acronis VSS agent tells the Microsoft VSS service to create a snapshot. The Acronis VSS component is not actually doing the snapshot. Somewhere along the line it gets confused and goes into some sort of loop that it cannot get out of, thus the mouse movement, but no response. You will note that you can still ping the server. A reset button or power switch is about the only solution for the GSOD.

    Supposedly Acronis has fixed this issue in its latest release, but it has not been integrated into Kaseya yet.

    Legacy Forum Name: BU-DR,
    Legacy Posted By Username: rcspang