Kaseya Community

Acronis broken install fix 101

  • The SAGA.

    had a Citrix server running perfectly, backups working 100% spot on, test DR performed and made the client fully chuffed.

    MYOB version 11 arrives....

    Another tech goes onsite to upgrade and publish MYOB 11, during the MYOB install a rather generic warning pops up saying "Another installlation is in progress, do you want to reverse the changes made by this installation and start a new one?" or something similar.

    Tech hits "yes"

    All hell breaks loose....

    Acronis fails that night so i try a Kaseya pushed reinstall, no dice, get the same registry error as i have been getting on one of my Exchange VM's

    "reg key blah blah uninstall not possible" and in the log "earlier version blah blah"

    appears the reinstal;l process/agent is looking for a key oin HKLMSWMSWINCVUninstall with a random key [487642378872537657635] or similar to uninstall a product that doesn;'t exist, nor does the key.

    SO, tried EVERY suggestion on here, and the one from Kaseya support of cleaning registry, rebooting, blah blah, even had a go at importing the reg key from a successful install to give the script something to reference during what it thought was a "reinstall", no dice.

    Tried one last reboot of the MF1 for yet another attenmpted fix.....BSOD. Heart attack....last backup was 2 days before as acronis had been mashed then.....oh hell....

    So went onsite with a disk, tried a long shot, imaged the c: drive then tried a universal restore with the image from that day hoping stripping the HAL would be enough to get me an OS if nothing else. Got me further, with an error i thought i would be able to fix but time was running short, client losing production etc etc.

    At this point i thought "time for the long fix" restored from the 3 day old c: backup then copied all the changed files from the current day back over, cleared the kerberos channels so i could logon to the domain on the restored server, Whew!!!! all good, client happy without knowing how close to death they were.

    GETTING ACRONIS INSTALLED AGAIN.

    UR'd my images of theserver to a VM to get something to work with (NOT touching the production sevrer again, lesson learned).

    Download the full Acronis product trial from their website (acronis.com)

    install the trial. ensure ALL components install correctly.

    Push an install from the Kserver, be logged in on the console to OK the "File being copied is older than current file" dialogs.

    Try a backup, backup fails "Invalid Product Key" message. DAMN! copy images already on system to new folder so an "uninstall" doesn't delete them all on me.

    Uninstall works PERFECTLY!!!!!!!!!!!

    Push a new install from kserver...PERFECT!!!!!!!!!

    System now running 100% spot on. Backups at this site run to a Thecus with 1/2 iSCSI target and 1/2 Raid 5, the thecus then FTP's the data to a removable drive in a Shuttle Linux box with VMWARE server installed, from here the removable is taken offsite daily, and we can remotely recover any downed server (with a valid image) into a VM in under 1.5 hours. On a whole this is an awesome system, just wish we had more comprehensive support for these types of issues!

    (soorry for the lengthy post but hopefully it will help some of you out)


    Legacy Forum Name: Acronis broken install fix 101,
    Legacy Posted By Username: bruce.muir
  • Thanks for the post. These types of stories are the real value of this Forum.

    Legacy Forum Name: Backup Tab,
    Legacy Posted By Username: ACTIONSC
  • Whhat did you do an uninstall of towards the bottom (Acronis, or an uninstall through Kaseya)?



    bruce.muir wrote:
    The SAGA.

    had a Citrix server running perfectly, backups working 100% spot on, test DR performed and made the client fully chuffed.

    MYOB version 11 arrives....

    Another tech goes onsite to upgrade and publish MYOB 11, during the MYOB install a rather generic warning pops up saying "Another installlation is in progress, do you want to reverse the changes made by this installation and start a new one?" or something similar.

    Tech hits "yes"

    All hell breaks loose....

    Acronis fails that night so i try a Kaseya pushed reinstall, no dice, get the same registry error as i have been getting on one of my Exchange VM's

    "reg key blah blah uninstall not possible" and in the log "earlier version blah blah"

    appears the reinstal;l process/agent is looking for a key oin HKLMSWMSWINCVUninstall with a random key [487642378872537657635] or similar to uninstall a product that doesn;'t exist, nor does the key.

    SO, tried EVERY suggestion on here, and the one from Kaseya support of cleaning registry, rebooting, blah blah, even had a go at importing the reg key from a successful install to give the script something to reference during what it thought was a "reinstall", no dice.

    Tried one last reboot of the MF1 for yet another attenmpted fix.....BSOD. Heart attack....last backup was 2 days before as acronis had been mashed then.....oh hell....

    So went onsite with a disk, tried a long shot, imaged the c: drive then tried a universal restore with the image from that day hoping stripping the HAL would be enough to get me an OS if nothing else. Got me further, with an error i thought i would be able to fix but time was running short, client losing production etc etc.

    At this point i thought "time for the long fix" restored from the 3 day old c: backup then copied all the changed files from the current day back over, cleared the kerberos channels so i could logon to the domain on the restored server, Whew!!!! all good, client happy without knowing how close to death they were.

    GETTING ACRONIS INSTALLED AGAIN.

    UR'd my images of theserver to a VM to get something to work with (NOT touching the production sevrer again, lesson learned).

    Download the full Acronis product trial from their website (acronis.com)

    install the trial. ensure ALL components install correctly.

    Push an install from the Kserver, be logged in on the console to OK the "File being copied is older than current file" dialogs.

    Try a backup, backup fails "Invalid Product Key" message. DAMN! copy images already on system to new folder so an "uninstall" doesn't delete them all on me.

    Uninstall works PERFECTLY!!!!!!!!!!!

    Push a new install from kserver...PERFECT!!!!!!!!!

    System now running 100% spot on. Backups at this site run to a Thecus with 1/2 iSCSI target and 1/2 Raid 5, the thecus then FTP's the data to a removable drive in a Shuttle Linux box with VMWARE server installed, from here the removable is taken offsite daily, and we can remotely recover any downed server (with a valid image) into a VM in under 1.5 hours. On a whole this is an awesome system, just wish we had more comprehensive support for these types of issues!

    (soorry for the lengthy post but hopefully it will help some of you out)



    Legacy Forum Name: Backup Tab,
    Legacy Posted By Username: Coldfirex
  • The uninstall was of the Backup Software only form the kaseya interface, only after "upgrading" fromthe Acronis DEMO to the "Kaseya Acronis"

    Legacy Forum Name: Backup Tab,
    Legacy Posted By Username: bruce.muir
  • Hi Bruce-

    Sounds like you've got a great setup there! Couple of questions:

    - So the Thecus box and the Shuttle are both on the customer's site, right?

    - What's the procedure for getting a downed server up in vmware? Do you keep a blank server virtual machine with a Kaseya restore CD image and then you just boot that remotely and point at the image?

    - Since you've got a bit of equipment cost, if I can ask, how much does the customer pay for this sort of setup? Do you have em buy the hardware or is it all built into the service plan?

    Thanks for the great post!

    Bill Street


    Legacy Forum Name: Backup Tab,
    Legacy Posted By Username: bds42