Kaseya Community

Backups failing on some Windows 7 and 2003 server systems because of Acronis Managed Machine Service -- am I alone?

This question is not answered

Starting around October 12th, a number of workstations and a server I have scheduled to backup have constantly failed. The error given through Kaseya is "Backup failed - Failed to connect to Acronis Managed Machine Service. Failed to establish the local connection with Acronis Managed Machine Service. Make sure that the service is installed and its status is Started. | Error: 0x30002 The system cannot find the file specified."

It gives a link to here for resolution of this problem:

https://helpdesk.kaseya.com/hc/en-gb/articles/229020348

However the problem doesn't seem to be credential related.

When investigating the machines, indeed that service is not running.  If I start it, it shows running for a split second before showing as not running.  No errors are given.

Is anyone else experiencing this problem?  I've already opened a ticket with Kaseya.

I've tried reloading BUDR but that hasn't helped.  I've also tried restoring from the last known good backup and that works, until something happens overnight. -- perhaps windows updates.

We're still on 9.2.0.22, and BUDR is 11.5-43800



Typos
[edited by: Zestysoft at 2:26 PM (GMT -8) on Nov 7, 2016]
All Replies
  • This has been the fix for me. Got is from the forum somewhere. Step 3 fixes it most the time.

    1. Rename the C:\ProgramData\Acronis\BackupAndRecovery\MMSData\DML folder (do not delete)

    2. Try to Start the service.

    This will recreate this folder and the internal database. Warning! recreating this database will remove your configurations and all of your backup plans from the agent and can, in certain cases, cause weird warning/errors related to non-existent items to appear in your logs.There are ways to avoid this, but they depend on your configuration and each individual case should be taken care of through a support ticket.

    3. If the service still does not start, rename the "C:\ProgramData\Acronis\BackupAndRecovery\MMS\events.db3" file. This file contains all the logs for the agent.

    4. Try to start the service one more time.

    5. If the service still stops, you can try completely uninstalling the agent, checking to make sure the C:\ProgramData\Acronis directory is removed and then reinstalling the agent.