Kaseya Community

BUDR 3.2 says VSS not used

  • Howdy,

    We upgraded an agent to BUDR 3.2 and ran a full backup last night.  VSS is enabled and the backup/verify worked correctly via the Kaseya logs.  However if we look at the logs from under Backup Sets it says "Warning! Unable to use VSS".  Has anyone seen this before?

     

     

    <!-- function f(e){ if (e.className=="ci"){if (e.children(0).innerText.indexOf("\n")>0) fix(e,"cb");} if (e.className=="di"){if (e.children(0).innerText.indexOf("\n")>0) fix(e,"db");} e.id=""; } function fix(e,cl){ e.className=cl; e.style.display="block"; j=e.parentElement.children(0); j.className="c"; k=j.children(0); k.style.visibility="visible"; k.href="#"; } function ch(e){ mark=e.children(0).children(0); if (mark.innerText=="+"){ mark.innerText="-"; for (var i=1;i<e.children.length;i++) e.children(i).style.display="block"; } else if (mark.innerText=="-"){ mark.innerText="+"; for (var i=1;i<e.children.length;i++) e.children(i).style.display="none"; }} function ch2(e){ mark=e.children(0).children(0); contents=e.children(1); if (mark.innerText=="+"){ mark.innerText="-"; if (contents.className=="db"||contents.className=="cb") contents.style.display="block"; else contents.style.display="inline"; } else if (mark.innerText=="-"){ mark.innerText="+"; contents.style.display="none"; }} function cl(){ e=window.event.srcElement; if (e.className!="c"){e=e.parentElement;if (e.className!="c"){return;}} e=e.parentElement; if (e.className=="e") ch(e); if (e.className=="k") ch2(e); } function ex(){} function h(){window.status=" ";} document.onclick=cl; -->

    <?xml version="1.0" encoding="UTF-8" ?>
    - <log uuid="F1DD1F44-32FD-4ED0-8701-32DC86E56E1F" product="Acronis True Image Echo Server" version="9.7" build="8319">
      <event id="1" level="4" module="100" code="0" time="1282168887" message="Wednesday, August 18, 2010 5:01:27 PM === Warning! Unable to use VSS" />
      <event id="2" level="2" module="1" code="1008" time="1282168887" message="<bold>Create Full Backup Archive</bold><endl/><tabpoint value=30><indent value=4>From: <indent value=10><textcolor value="navyblue">Disk 1</textcolor></indent><indent value=4><endl/>To file: <indent value=10><textcolor value="navyblue">"\\192.168.0.253\share\MIT_Local\99368806\VolBackup\20100818 17.00.49\volBackup.tib"</textcolor></indent><indent value=4><endl/><textcolor value=0x00ff0000>Password protected</textcolor><endl/>Compression: <indent value=10><textcolor value="navyblue">Normal</textcolor></indent><indent value=4><endl/></indent>" />
      <event id="3" level="2" module="100" code="0" time="1282168890" message="Wednesday, August 18, 2010 5:01:30 PM === Operation 1 of 2 == Creating partition image == Hard disk: 1 == Drive letter: C: == File system: NTFS == Volume label: == Size: 148.9 GB ==" />
      <event id="4" level="2" module="100" code="0" time="1282169606" message="Wednesday, August 18, 2010 5:13:26 PM === Operation 2 of 2 == Saving partition structure == Hard disk: 1 ==" />
      <event id="5" level="4" module="100" code="2" time="1282169606" message="Wednesday, August 18, 2010 5:13:26 PM === Operation has succeeded." />
      </log>

  • We deployed BUDR 3.2 to another machine (also 2003 with latest VSS rollup) and are seeing this still.  Could someone with BUDR 3.2 deployed to a machine that is using VSS check the backup set logs to see if this is occurring for them also please?

  • is there any other backup software  installed that also uses VSS ? BUDR 3.2 has a problem with that

  • Nope.  They just had BUDR 3.1 previously.  

  • Has anyone not tested out BUDR 3.2 yet or am I the only one with this issue?

  • FYI, there is a bug in the BUDR 3.2 Acronis build that causes VSS to not be used at all.  I was told that a new build of Acronis would be needed to resolve, but they have no idea when that will be.  For reference: CS022293

  • If you are upgrading from a previous build then you need to run the following Procedure.  If you are installing it new, you should not see any problems with VSS.

    <?xml version="1.0" encoding="utf-8"?>
    <ScriptExport xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns="http://www.kaseya.com/vsa/2008/12/Scripting">
      <Procedure name="Remove Acronis VSS Provider Key" treePres="3">
        <Body description="">
          <If description="">
            <Condition name="CheckVariable">
              <Parameter xsi:type="StringParameter" name="VariableName" value="#vMachine.OsInfo#" />
              <Parameter xsi:type="EnumParameter" name="Condition" value="Contains" />
              <Parameter xsi:type="StringParameter" name="Value" value="x64" />
            </Condition>
            <Then>
              <Statement description="Delete the specified registry key on 64 bit systems." name="DeleteRegistryKey64" continueOnFail="false" osType="Windows">
                <Parameter xsi:type="StringParameter" name="Path" value="HKey_Local_Machine\System\CurrentControlSet\Services\VSS\Providers\{f782463b-33bb-4043-ad8d-60b728d26a6c}" />
              </Statement>
            </Then>
            <Else>
              <Statement description="Delete the specified registry key - Regedit displays keys as folders and values as documents." name="DeleteRegistryKey" osType="Windows">
                <Parameter xsi:type="StringParameter" name="Path" value="HKey_Local_Machine\System\CurrentControlSet\Services\VSS\Providers\{f782463b-33bb-4043-ad8d-60b728d26a6c}" />
              </Statement>
            </Else>
          </If>
        </Body>
      </Procedure>
    </ScriptExport>

  • I had the same problem on upgrading.   I ran the reg key and did what they said.  I did not try the script.   What worked for us was an removal through the add/move on the server of Acronis.  Once removed we just reinstalled and everything worked ok.

  • This is on new installs and a couple upgrades.  Acronis confirmed this is a bug though.

  • Dev still has no idea about getting a fix for this from Acronis...

  • We have a couple of new servers that this is happening on.    We have even tried to deinstall and reinstall and same proble with VSS.   Same reply from support stating that it is a bug an no ETA.    The only option is to stop the services and restart.    I am wondering when kaseya will cone out with a version that works from start to finish.