Trouble booting restored backups of SBS 2011

Forums

Forums
Forums, discussions, and Q&A for all products.

Trouble booting restored backups of SBS 2011

This question is answered

I'm trying to restore SBS 2011 servers to dissimilar hardware with very little luck. They will finish restoring with no problems, but will never boot. They post and then reboot, never getting to the windows splash screen. I've tried various builds of acronis 10 and 11 and a multitude of drivers. Is anybody else having similar issues?

Verified Answer
  • Sorry I haven't responded in a while. I was able to get two different SBS2011 servers to boot.

    I restored just the system reserved and system partitions. Then I booted into the recovery environment and used bootrec /fixboot, /fixmbr, /rebuildbcd. I rebooted again and back into the recovery environment. I used startup repair (cd recovery --> startrep.exe). Then I booted Acronis 11 and used universal restore to slip in just the mass storage driver (and nothing else). After that it boots just fine. The driver in question was Intel(R) Desktop/Workstation/Server Express Chipset SATA RAID Controller, or

    Intel(R) Desktop/Workstation/Server Express Chipset SATA AHCI Controller, depending on the disk setup. It all seems kind of obvious now.

    Before, I always loaded the 'all' folder for the drivers. I installed SBS2011 clean on the machine and found the specific drivers that were installed, and used just the one driver to try and isolate the problem. After it boots and I install all the other drivers, I have no problems.

    Mark, I will keep that in mind if my process doesn't work again for some reason.

    Thank you everybody for your advice. It was very nice to know that people were willing to help.

All Replies
  • Yes, I have had this error many times before.  Try running a startup repair from the Windows installation DVD (or iso for VMs)

    Cheers,

    Ed.

  • Thanks for the suggestion, but that's been part of my usual routine for restores for a while now. Let me elaborate a little.

    I am not able to use universal restore during the restore. The option doesn’t even show up. I need to apply it after the restore is complete. After restoring, it will give a bootmgr is missing error. Trying to load drivers in acronis at this point won’t work, because it doesn’t recognize the disk as having an operating system installed. I then go into the recovery environment using an sbs2011 installation flash drive and use bootrec (fixboot, fixmbr, rebuildbcd). I then reboot. Still getting the bootmgr is missing error. Boot into recovery environment again and use startup repair. Now it just posts and reboots endlessly without ever seeing a windows splash screen. I load drivers using universal restore. No change. Safe mode ends at loading classpnp.sys and reboots.

  • In case you have not already seen it, the best place to start t/shooting this would be our Recovery Guide. This KB links directly to the relevant section - community.kaseya.com/.../troubleshooting-universal-restore.aspx

  • I read through the troubleshooting guide and I've already tried what is relevant to me (nothing over a network). The only driver issue is that universal restore always complains about the 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1 and #2. Oh, my board is an Intel Server Board S1200KP - ark.intel.com/.../Intel-Server-Board-S1200KP. If anybody has any tips on drivers, please let me know.

    I've tried restoring both to a single SATA drive in AHCI mode and two drives in a RAID 1 array. Same result for both of them.

    I've found these articles which lead me to believe that SBS2011 isn't quite fully supported yet.

    kb.acronis.com/.../19846

    kb.acronis.com/.../2757

    I don't know how I didn't mention it in my opening post, but I was able to restore an SBS2011 server successfully once. I've tried the same process on the same backup to the same hardware, but I can't reproduce the success. That's what's really bothering me. I know it's possible, but I can't do it again. I'm evidently not doing something exactly as I did before, but what that is is totally lost on me now.

    Perhaps it has to do with how I'm arranging the drives. This is how they are on the actual server (the restores I'm doing now are just for testing purposes). If I were to restore just the first disk, what combination of primary/logical/active would you suggest I select when restoring?

  • whoops, didn't insert the image right.

  • Bump

    Any advice at all would be greatly appreciated. Thank you.

  • If I have understood your post correctly, the UR restore process completes successfully, but when booting the restored system it gets stuck in a reboot loop and never completes loading the OS?

    If this is the case, please review step 6 of this KB - community.kaseya.com/.../operating-system-does-not-boot-after-restore-using-acronis-recovery-cd-universal-restore.aspx (this is linked from the last step of the guide I posted before)

    I expect the issue here is not with the disk layout, otherwise the restore would not complete, but it may be the restored system crashes when loading the USB controller or other driver.

    I would recommend opening a support ticket if this still does not help. If I have understood the symptoms correctly, we would need the data mentioned in the above linked article to troubleshoot further.

  • This has happened three times when i have done restores with acronis (I have only done three.  Every time I booted from my Shadow Protect IT edition pen drive and the problem was fixed doing an HIR

  • Graham, thanks for replying, but I'm not quite sure what you are suggesting. Could you please explain a bit?

    I've also opened up a ticket with Kaseya, who says that they will try and get Acronis involved.

  • I have had no success with the acronise bare metal recovery.  It has never rebooted.  After I get the perfunctury blue screen  I reboot the server using my Shadow Protect IT edition pen drive.  I do a HIR (Hardware Independant Recover0 which fixes the boot devices and it then starts OK

    What I am suggesting is that Acronise is not very good at hardware independant recover and Shadow Protect is

  • I am not sure if this applies or not, but I thougth I would mention in it in the spirit of helping...

    You mentioned you were seeing the message 'BOOTMGR is missing' after a reboot.  We had a similar issue with an SBS2011 server last week. It was not related to doing an Acronis restore.  It was the result of doing a restore using the ShadowProtect software. We were restoring an image of the data volume (not Operating System), but chose a wrong option during the restore, and set the data volume to Active.

    We used the following Microsoft article, and were abel to fix the problem pretty easily.

    Windows Small Business Server (SBS) 2011 fails to boot with error 'BOOTMGR is missing'

    support.microsoft.com/.../2501318

    Again, I am not sure if this will fix your problem, but I just wanted to mention it.  Hope it helps!

    Lloyd

  • @GrahamLove

    Thanks for clarifying. We don't have Shadowprotect, but I've just applied for the 3-day trial to see if I can manage to create some sort of recovery media.

    @lwolf

    Thanks for the advice. I'll make doubly sure that the reserved partition is marked as active on my next restore.

  • I haven't heard anything from Shadowprotect yet.

    Marking the system reserved partition as active didn't change anything.

    I'm currently doing a clean install of SBS2011 on the server I was attempting the restores on. It's installing fine for now. I'm going to load all drivers and such and make sure I've been selecting the correct ones to apply during universal restore. I'll let everybody know how it turns out.

  • @dumberger,

    Sorry to hear that marking the system reserved partition as active didnlt work for you.  I thought maybe that was it.

    Lloyd

  • When testing appassure I had to do this to fix my server.  Boot with System and get to console..

    Make sure my paritions drive letters were correct (and if not, correct them using the diskpart options).

    Then used

    bcdboot C:\Windows

    Voila...up and running just fine