Kaseya Community

Backup failed - Failed to find hard disk 2.

  • Backup failed - Failed to find hard disk 2.

     

     

    K2 with Kaseya Backup version 10.0-17552 on a Win 2008 R2 Standard server. Installed and when scheduling under Machine Group ID - Disks it Shows only drive 2 with a check box. Drive 1 does not list here at all.  This is a single Raid 5 Array with 2 partitions but only one physical volume.

     

    I Cleared the Audit cache of the machine with a procedure. Reran the System info and Latest Audits, didn't change the state of the drive there in the backup. Was considering reinstalling the backup agent, but we only have the exact number of licenses as we do machines. Worried about messing it up without a little guidance.

     

    Thanks for any of your help

     

    Kevin

  • I ran into this as well, what I did was I switched credentials from the network admin to a local admin

  • I have that setup already. I create a Local Admin on the machines when the agent is installed. We had to reload this machine and then remake it the secondary DC, but it was running the same OS and was working prior to the reload. It's just sort of weird how it pick up an incorrect drive. I think I am just going to reinstall the backup on the machine and see what happens.

  • I ran into same situation, Acronis was confused finding Disk2

    In my case the Dell server turns out that it has a DRAC4 which by default includes a virtual drive which you can use to mount an ISO.

    Windows sees that as Drive1 and C:\ as Drive2, however when nothing is mounted, Acronis sees C:\ as Drive1 and can not find Drive2, therefore failing.

    I disabled this virtual drive and ran a baseline audit to make sure Acronis always sees C:\ as Drive1. This resolved the issue for me. You may like to check any such similarity in your case

  • There is a problem with the acronis software and recognizing the drive properly.  I have a ticket thats been open for about 4 weeks now and I believe acronis is working on a fix for this.  I would submit a ticket and they should be able to keep you updated on the progress.  I know we believe we have the commands figured out to get around this and now they are just integrating.

  • Bryan any time frames on a hotfix for this. I have a server that currently is not being backed up and were getting ready to some major upgrades to it this week.

  • Got tired of waiting for a new response from my ticket, so i completely removed the Kaseya agent and backup from this server and started over. reinstalled everything and still the same problem. It shows drive 1 and 2 until it verifys the install, then when you go into schedule the backup it only shows drive 2 with the C and D partitions on drive 2 no drive 1. So the backup is going to fail again.

    It appears that what rajeev posted earlier is indeed the problem. But I hate to disable the Virtual drive for this as it makes the Dell open manage services unusable I believe. we should be able to select this anyway. Or edit it in some manner to correct the issue. The strange thing is, Prior to the server reload, this worked just fine. Not sure what would be different now. Same Server, same operating system install everything.

    I am at a loss now.

    Kevin

  • Support came in and adjusted the settings in the database to make mine work for now. Just cant run an audit till the Hotfix comes out for it. Sounds like they are doing it pretty soon. But I have completed 1 Full and one incremental backup since they changed it. Thanks Support for fixing that.

    Kevin