Kaseya Community

BUDR 4.0 Unable to Mount or restore from Backups

This question is answered

Hello All.

I've been running a controlled roll out onto our customer servers of BUDR 4.0, and the associated testing I perform with each rollout.

On the limited machines that have been upgraded to BUDR 4.0, I've noticed a common problem which has me worried.

Not even ONE of the machines that I've upgraded to BUDR 4.0, am I able to restore from.

The backups run perfectly, verify ok, but through Kaseya, I can't mount the images.  Any of them.

Using the Kaseya UI for BUDR, I also am unable to mount any of the backups.

Has anyone seen this before???????????

Jason.

Verified Answer
  • Hello All,

    I've got an update.

    This is confirmed as an Acronis problem.  What appears to be happening is that Acronis times out when attempting a mount.  

    If I backup to a drive in the server itself, it will mount the images no problem, and lightning fast.

    If I backup to a network source, Acronis is unable to mount the backup images.

    It appears that due to network speed, the mounts fail.  Acronis is not getting a response back in the time it expects, so it fails the mount.

    Acronis themselves are connecting through to some of our servers to prove this.

    Support have said it may not be possible to have a fix for this until Acronis 11.

    Jason.

All Replies
  • Hey Jason I have seen plenty of these. It turns out that we had to make sure the server and the NAS were on the same switch due to network issues.

    You can also try moving the tib file to an external USB drive and mounting that way.

  • I have the same problem, and my Nas is connected directly to the server on the second NIC card. I have also tried to backup to a usb device, no luck. I can open, browse and even extract the files but cannot mount. I thought it might be harware problem and had the supplier test the server and they gave it the thumbs up. I dont know what i should try anymore. I had to go on site and make a backup so that i can restore the server if needed.

  • What is the error and or the volBackupLog.xml errors when you try to backup to usb device?

    Try backing up a different volume on that server, if it still fails run a check disk on the server then reboot and try again.  

  • Hi Migs , there is no error at all my backup logs shows that the backup was successful even with verify if i backup to NAS or USB. Could my internet connection speed from the office have an effect on the mounting process?

  • Pieter the internet connection should not matter, it's the internal network where the NAS and server that counts.

  • Kaseya upgraded us to the new build 10-18058.  And I tested it out on my home PC.

    Before upgrading I took a fresh new backup ~250gb. Tried to Mount it and got the error String Reference not set to an instance of a String. Parameter name: s and when trying to convert to .vhd got "failed to convert image"

    After upgrading to the new build which "doesnt need a reboot" but check the box not to reboot when you install it from VSA because it will reboot if you do not. I was then able to convert the image to .vhd and at first I still couldnt Mount the backup but Kaseya Tech uploaded the updated AcronisManager.dll file to our VSA server here C:\Kaseya\WebPages\ManagedFiles\VSAHiddenFiles\BUDR    and I guess if you run a full backup, verify install or when you upgrade to the new build, that machine will get this new file. And then I was able to Mount images.

    Overall, so far so good with recovering that we havent been able to do in past 5 months.

  • That's encouraging news, Tim, thanks. Now all we need is for this build to get released "into the wild"...