Kaseya Community

Software Management - now Windows 10 reboots

  • We've been using software management for about 45 days, and most machines are generally ok aside from bandwidth issues. I have a machine that reboots a couple times a week. It's a laptop that is only online when the user is active, and I think Windows Update is running and prompting for reboot. Is there no way to disable Windows Update? Patch Management says Automatic Update not supported. 

    I'm consider adding a registry entry/group policy. I know Microsoft is more aggressive with updates, but I would like to to encourage it to some sort of schedule in some way.

  • Hi Brandon, did you get any sort of response to this query?  I had a few PCs reboot without warning last week, even though the software management policy says that it should prompt the user to reboot.  

    I had to remove all PCs from SM until I work out why this happened as users lost data due to the reboots.

    Input from Kaseya would be great in regards to Software Management issues...

  • I turned off reboots on all the profiles in SM. Then added pre and post agent procedures. Before it updates, it sets a custom variable to 0, then after the update, sets it to 1. Pre reboot to 1, and post reboot to 0 just in case. Then I have a policy that schedules a reboot every day at 4:00 for machines with that variable set to 1. That way it will only reboot at 4:00. This is a HUGE workaround for something that should be included as a feature. So far so good.

    Also, bandwidth is a huge issue. We have 2 policies at first, now we have 8 I think. 3 per day to run at 19:00, 23:00, 2:00, and 3 days a week or so. All that to space out the installs.

  • Hi, we had many complaints the last 2 weeks about Endpoints rebooting with no notification and all updates are deployed with SM. I got a reply from support stating it was an issue with the setting in the deployment profile, we use the setting "Skip Reboot" when a user is logged in. We had to change it to "Do not reboot after update, send email to..." .. but this did not fix the problem.

    Later on support mentioned that there is a problem with KB4487038, original reaction:

    There appears to be an issue with a patch KB4487038 rebooting the machine. This is most likely because the /norestart switch is missing from the INSTALL command.

    The Partner Support Team have advised that the switches for Patch KB4487038 match the information provided in the Microsoft Update Catalog:

    Restart behavior: Never restarts

    May request user input: No

    Must be installed exclusively: Yes

    Requires network connectivity: No

    Uninstall Notes:

    Not Uninstallable

    Uninstall Steps: n/a

    The patch itself does not require a restart but it must be installed exclusively. Before other patches are installed the machine must be rebooted but the install of this patch on its own does not require a reboot.

    This patch does not contain a /norestart switch but also does not contain a "chainable" switch -c. The next installed patch in the logs does contain a "chainable" switch -c which is why the reboot occurred.

    I would recommend that you deny this patch for the time being as a workaround. I have not had any reports of other patches causing this issue at this time.

    You have to create an override policy to reject the KB4487038 update.


    Hope this helps?

  • That would make sense. I still wonder if the reboots were native windows updates or SM, Also, a reboot in the middle of the night is acceptable but because of the bandwidth issues with SM, the updates finish after the workday starts.

    Either way at this point the update is mostly pushed out so it should be a non-issue.