Kaseya Community

9.5.0.20 Patch Release - 03 April 2019

  • Hey guys,

    Here are the latest notes from our most recent release.

    ------------------------------------------------------------

    The VSA 9.5.0.20 release includes features and bug fixes. See the topics below for details.

    IMPORTANT! This release requires agent version 9.5.0.11. Be sure to update your Windows, Mac, and Linux agents after installing this release.

    Feature

    Security Enhancement

    • A security vulnerability notification is sent if a someone attempts to create a user with a known malicious naming convention. This release enhances the notification to include specific information about who attempted to create the user and the IP address of the machine that they used. (VSA-4464)

    Bug Fixes

    Agent Procedures Module

    • Fixed an issue that resulted in the agent being Out of Compliance if the agent and VSA were in different time zones and the agent policy included the Exclude the following time range option. (VSA-880)

    Audit Module & REST API

    • Fixed an issue where PUT calls to assetmgmt/assets/{agentId}/customfields/{fieldName} were not updating the correct custom fields. (VSA-3776)

    AuthAnvil Integration

    • Two Factor Authentication (2FA) is now always enforced when 2FA is turned on in VSA, even if the AuthAnvil authentication policy has disabled 2FA. (VSA-3806)

    Classic Monitoring Module

    • Fixed an issue with Monitor > Dashboard > Dashboard List that could cause a dashlet to display information belonging to a different dashlet under certain conditions. (VSA-5069)
    • Fixed an issue where the Monitor Sets service list was empty if the set had more than 600 services. Now, the list contains a maximum of 500 services, and a search filter has been added. Enter text in the filter to display only services containing the string you entered. (VSA-380)
    • Fixed an error that prevented copying Monitor Set folders from one cabinet to another. (VSA-378)

    Database & Schema

    • Fixed a performance issue by adding a highly needed index. (VSA-621)

    Installers

    • Fixed an issue that caused VSA offline installation to fail. (VSA-5139)

    Live Connect & Remote Control

    • When starting a Live Connect session, an upgrade dialog now displays if a new version of Live Connect is available. (VSA-4195)
    • Fixed an issue where events were sometimes listed with the wrong icon in the Live Connect event viewer. (VSA-3697)

    Patch Management Module

    • Fixed an issue where approved patches were not being installed by automatic updates. (VSA-4802)

    Security Vulnerability & System Module

    • Fixed a security vulnerability on the Login page. (VSA-3964)

    SOAP API

    • To harden security, DTD processing has been disabled for this endpoint: KaseyaWS - External XML Entity Reference. (VSA-3078)

    Software Management Module

    • Added an index to enhance Software Management performance. (VSA-291)

    System Module & VSA Core

    • Fixed an issue with Mac OS agents reporting invalid current date times with the year 1904. These invalid dates prevented alerts from being generated. (VSA-1974)



    -
    [edited by: Jenny Escobar at 5:33 AM (GMT -7) on Apr 4, 2019]
  • Hi Oscar,

    Thanks for the update! But I am missing the 1-Click Access feature as described in the latest March newsletter:

    Why is this not released?

    Kindest regards,

    Edwin

  • Anybody braved this one yet, and care to share how things went/have gone?

  • I updated our demo VSA without problems so far and was gonna update the production VSA later this week but I just got notified by the Bitdefender support that this version breaks their TAP application. So now I'm waiting for their approval.

  • I really hope this fixes the terrible performance we have has since the .10 agent update for the 9.5.0.18/19 updates. Our NOC techs have freezing sessions, high 4 digit latency, and disconnects. didnt have any of these problems before the .10 agent updates. Almost unbearable.

  • same here.

  • I still haven't updated from 9.4 and each of these posts is why.  As the upgrade installs the latest patch, I need a patch that actually produces a stable system!  I've scheduled a cancelled a weekend 3 times so far

  • I've updated the Test environment but will be holding off until next week before updating Production...

  • I updated ours last night... Thus far no *new* major issues.

  • I updated our new production server that was impacted by a bug where API-based writes to custom fields were writing incorrect Tenant (partition) IDs. This affected the ability to see custom fields in QuickView or drive views that reference the custom fields. One tenant worked fine but the other tenant failed.

    After updating, the problem did not go away - but - after removing the policies, views, and custom fields and putting everything back, it all works, so it looks like that problem is solved. I'm not seeing any other issues, but we've only migrated around 100 of 3100 agents over so far.

    Glenn

  • just got news in that there is an update address our freezing issue in the next patch or two

  • Upgraded two days ago and so far, no new issues except the upgrade did not go easily. Had to re-install three times to get patches to install properly. After the third try, we got thru the process but had to manually kick off the Scheme update.

  • Here's my update experience.   I had 9.5.0.15 and had not patched in awhile b/c of all the problems with the recent updates.  Since I didn't see any reported issues with .20, I went ahead and braved the update.  Install went as expected; however, after reboot logging into the VSA a notice popped up that 5 different services hadn't started.   These were all services with "Automatic (Delayed Startup)", starting any of them resulted in the service started successfully, then ended, informing service would only start as needed.   Also now all of the interface screens showed "Evaluation Edition" branding, even though it should we were fully licensed.

    Kaseya tech support was responsive, running the schema update didn't fix, nor did rebooting, etc.   Ended up finding out this was just part of the customization settings and was easily changed under settings.  Don't know why it decided to change on it's own after update.

    The other problem I've had is on my workstations trying to connect to liveconnect (remote control), I was prompted to install the new version of liveconnect.   On Windows 7 32bit OS, when I attempted to run after installing, I received a Windows error that the problem was not responding.  Rebooted, same thing.   Uninstalled and re-installed the liveconnect client and now it is working.

    On my main Windows 10 64-bit workstation, I was also prompted to install the new version, which did, but then anytime I tried to remote control a small popup window would appear and disappear.  Tried rebooting, checking firewall settings, etc, etc.  no avail.   Uninstalled, rebooted, reinstalled, no avail.   Tried more troubleshooting, but before contacting Kaseya support I  uninstalled, rebooted and reinstalled the liveconnect one more time and now it seems to work fine.

    Will update if have any more issues.   Hope not!

    We run Kaseya Server in-house on Windows 2012 R2 Server, with 188 workstations being managed with the product.

  •  - Updated our test environment from 9.5.0.17 to .20 and ran into the same issue with services.  Ended up running the .20 install again followed up by a reapply of Schema that failed on the first attempt.  The second completed leaving our Test server with an Evaluation Edition branding.  The license code was still in place but our licenses for the server were not.  Contacted tech support to get an answer on what happened before attempting in production. (Ticket #355238) So far they keep reiterating that we have 50 NFR licenses associated to the server.  It was a mimic of our production box and used to show 6500 along with all of the module licenses. They have not been able to fix the issue as of yet...



    clarified "code" versus license
    [edited by: Tim Varvais at 5:46 AM (GMT -7) on Apr 15, 2019]
  • Thanks for sharing everyone, it makes me hesitant to upgrade to the latest 9.5.0.20 patch. As went from 9.5.0.17 to .20 that's the same path we'll be taking. Apart from licensing in testing, this doesn't seem to bad as he tells it. I do fear the Live Connect woes I've been reading about.

    If I screw up Live Connect with this update, or rather if the Kaseya update will, I'll be hogtied and hoisted in the highest available tree by my dear colleagues. It's not only our techs that rely on Live Connect on a daily basis, but we also deliver this as a service to some customers. And that's not something to take lightly. I'll try to get some information on this issue from Kaseya before choosing to wait or take the jump.....

    - Maybe you can shed some light if this is still an active issue in .20? Or is it known what goes wrong and is there a way around this?