Kaseya Community

9.4.0.32 Patch Releases - 16 November 2017

  • Hi All,

    We have just released Patch 9.4.0.32:

    http://help.kaseya.com/webhelp/EN/RN/index.asp#38514.htm

    9.4.0.32 Patch Releases - 16 November 2017

    Virtual System Administrator™

    • The agent version is updated to 9.4.0.15. (NINEFOURPT-713)
    • Fixed an issue related to file handling that would cause agents to crash. (NINEFOURPT-705/EES-1125)
    • Debugging features for the Kaseya Agent and Agent Endpoint services are added. This will take effect for new agent installs and updates starting with 9.4.0.15. If one of the services crashes, mini-dump files will be automatically created in C:\ProgramData\Kaseya\data\crashdumps. Only the most recent dump file is retained at any given time. Support may request for such file if crashes are occurring on a particular machine. (NINEFOURPT-714/EES-2038)
    • Resolved incorrect agent status behavior where agents would appear to be offline when it is online. (NINEFOURPT-734/2EES-1979)
    • Improved Endpoint fabric performance where managing backend tasks will be quicker. (NINEFOURPT-735/EES-2030)
    • Reduced the length of time P2P files are cached on endpoints. (NINEFOURPT-732/EES-2046)
    • Corrected a security issue where all agent procedures will end up being visible to end users. End users will now only see agent procedures that are associated with their machine roles. (NINEFOURPT-645/AF-2402)
    • Corrected an instance of tenant bleed where agents will check in the incorrect tenant. (NINEFOURPT-649/SDP-3377)

    Software Management

    • Added the ability to configure how many days an error is shown before being automatically deleted. (NINEFOURPT-706/SDP-3753)
    • Corrected an issue where a deployment schedule being independent of a blackout window schedule would improperly report being overlapped. (NINEFOURPT-703/SDP-3722)
    • Corrected an issue that caused policy overrides not to be registered correctly from Software Management. (NINEFOURPT-702/SDP-3830)
    • The percentage of machines vulnerable in the dashboard will now correctly take into account only Software Management-enabled agents. (NINEFOURPT-700/SDP-3827)
    • Deploying patches will now properly deploy without an error when combined with filters in columns. (NINEFOURPT-683/SDP-3740)
    • Fixed an issue that could cause scans not to detect recent OS patches. (NINEFOURPT-676/SDP-3774)
    • Added support for private profiles in Policy Management. (NINEFOURPT-650/SDP-3318)
    • Added a notification regarding using Force Update in Policy Management. A dialog will inform you that Force Update will ignore any blackout window and reboot options configured. (NINEFOURPT-719/SDP-3804)
    • Further improved performance by reducing messages required to be sent back to the VSA server from agents. (NINEFOURPT-673/SDP-3720)
    • Improved performance of initial scanning by consolidating them into a single file onto agents. (NINEFIVEPT-280/SDP-3837)
    • Added Architecture and Language columns for third party software profiles. (NINEFOURPT-672/SDP-3705)
    • Resolved an instance where patch scans would not work correctly on all machines. (NINEFOURPT-727/SDP-3877)
    • Corrected an issue where duplicate software updates and patches appeared. (NINEFOURPT-671/SDP-3691)
    • Fixed an issue with duplicate entries in the productVersion table where it interrupts scanning. (NINEFOURPT-670/SDP-3706)
    • Added the ability to assign third party licenses through Policy Management. (NINEFOURPT-728/SDP-3712)

    Discovery

    • Resolved an issue where “Use Directory Default” in Domain Watch was ignored and newly created VSA users defaulted to myOrg. (NINEFOURPT-220/DISMON-11)

    Live Connect

    • Addressed an instance where remote control sessions would sometimes fail to release the shift key when switching focus. (NINEFOURPT-679/AF-3139)
    • An end user denying a remote control request will no longer trigger an application error. (NINEFOURPT-697/AF-3037)
    • Corrected an issue that prevented private remote control sessions from connecting to Windows 10 machines with certain security settings in place. (NINEFOURPT-687/EES-836)
    • Live Connect will no longer receive an application error when connecting to an agent protected by security applications such as AVG (KES). (NINEFOURPT-640/AF-2977)
    • Live Connect will no longer receive an error with “Could not connect to server” when logged on the VSA with the -cdn.kaseya.net suffix. (NINEFOURPT-641/AF-2991)



    updated notes
    [edited by: Nicolas Ponce at 4:58 PM (GMT -8) on Nov 16, 2017]
  • After applying update, am unable to reapply schema... receiving this SQL error:

    Cannot insert the value NULL into column 'description', table 'ksubscribers.dbo.ticdescription'; column does not allow nulls. INSERT fails.

    **Update:

    Found what I suspect is a typo in the "core\script\cleanupData2.sql" file on line 1111:

    INSERT INTO ticdescription (noteTime, emailAddr, [description], ticketId, adminOnly, partitionId, machType)

    I removed the brackets around description:

    INSERT INTO ticdescription (noteTime, emailAddr, description, ticketId, adminOnly, partitionId, machType)

    Reapplied schema and it worked okay this time.



    Added possible solution
    [edited by: bmanning at 3:55 AM (GMT -8) on Nov 20, 2017]
  • We also had a similar issue when trying to reapply schema

    Fatal messagesys error: Monitorting/Constrats/DF_alertTemplateOverride_agentGuid.sql

    Now we can not start the Kaseya Event Services and Network Discovery service, therefore our system is down and I will need to raise a ticket tomorrow.

  • Hi

    I see that your server is up and running at this time. There is no need to run schema after the patch update. However, if you are still encountering any issues with schema please submit a Severity 1 ticket and one of our Support teams will assist you. Thank you.

  • Hi ,

    I just raised a Severity 1 ticket in your behalf, as your server is down. You should have received an email wit hthe ticket number and detials. A support technician will engage shortly. Thank you.

  • I see that Patch 9.4.0.32 is no longer shown on the patch release page.

    I have already installed Patch 9.4.0.32, so where does this leave me?

    I have not tried to reapply my schema.

    Also this is the second pulled patch in the space of a few releases, i.e. 9.4.0.30, for what was the also an issue when reapplying the scheme.

    Kaseya where is the Quality control?

    Andy

  • We have not pulled the patch.

    Those have schema issues seem to be related to third party modules such as Webroot. You do not need to run reapply schema but Support will assist with your issues if you run into a wall.

    If there's anything we're misunderstanding, please let us know.

  • Ok, when I was looking at the R94 Patch Releases webpage this morning the 9.4.0.32 patch was no longer listed and then I saw the comments about the patch, hence thinking it had been pulled.

    I have just gone back to the same webpage and it's back again, so not sure what's happening,

    So it's not a typo that bmanning has pointed out?  [description]

    Sorry for false accusation.

    Andy

  •  - Has the issue with Webroot been addressed? "Those have schema issues seem to be related to third party modules such as Webroot."  I would like to forego any downtime for a known issue....

  • Hi - We did suffered this issue with Webroot, both Webroot and Kaseya have started tickets. To my knowledge the issue is not yet resolved. At this time the Webroot module piece in Reapply Database Schema has been cut out, so it doens't bite us again....

    Kaseya support started a ticket with Webroot to solve the root cause of this issue. The Kaseya support guy that has the ticket open is Patrick O'Keeffe. The last update I got on this was exactly one week ago....

  • Webroot are still working on a resolution for the issues with the installation of the Webroot VSA Module but have not as of yet provided an ETA for when this will be fixed.

  • When is patch .33 being released?

  • By EOD today.

  •  

    Tentatively planned for today for on-premise customers and planned for release on Cloud/SaaS Saturday.

  • FYI - #222958 WEBROOT - Reapply of Schema error (Kaseya on-prem VSA 9.4.0.34)