Kaseya Community

9.5.0.21 Patch Release - 11 May 2019

  • Yeah we found this out over the weekend too - I've talked with management to hopefully get to them start updating release notes or something when they know there are issues and when they are yanking a patch.  

    *fingers crossed*

  • aaaannd...from the June newsletter:

    "VSA Release Status

    A performance issue was discovered late in the quality cycle for 9.5.0.21 which resulted in a delay with the release for on premises customers. To date, we have been able to effectively manage the issue across SaaS, but have decided that the best course of action is to continue to hold any further releases until we are confident that we have completely fixed the issue. We are working diligently on the issue and will continue to provide updates on progress. We apologise for the inconvenience. "

  • Interesting - other than the occasional 'refresh' issue, .21 has been running rather well for us.  

  • Craig how did you disable MSMQ logging ?

  • Tim are using the new UI or the old, are you using Live Connect or KRC?

    The new UI for us somehow half reverted back after a reboot; after KSupport worked with us, they had us enable to use old UI,

    We also saw some issues with the speed and latency of using Live Connect. KSupport had us also turn that off in favor of KRC (that connects in seconds)

  • see blogs.msdn.microsoft.com/.../changing-the-size-of-the-msmqlog-bin-logging-file-in-msmq

  •  Using new UI and Live Connect.  Surprised that they did not have you rerun the patch along with schema to address.  Very strange that they would have you using KRC rather than Live Connect unless your server performance is bad...?  FYI we are NOT running Software Management

  • On 17th Jun I upgraded my on-prem VSA to 9.5.0.20. This is the latest patch loaded.

    Am curious to explore one click remote connection.

  • One-click is dead in the water, IMHO. It requires NLA to be disabled, which opens everyone for the BlueKeep RDP exploit.

    This is because one-click access is build on KRC's private remote control feature (Which has never worked if NLA is on).  See helpdesk.kaseya.com/.../115007293107-Unable-to-establish-private-Remote-Control-session-OR-1-Click-Access-to-Windows-10-machine

  • As a potential "work around"  take a look at the new script I uploaded in the procedures forum... Theoretically you run it then use the One click, and it should work, then it disables NLA again within 5 minutes (or you could adjust it to be shorter).

  • Still no .22? Its nearly July.

  • Yeah - tickets taking months/years to address, lack of Kaseya Staff posting on these boards, and the sound of crickets when they put out a patch that breaks things (no follow up).  Really wonder what is going on with Kaseya these days.

    - that was a good idea that should have been implemented into the One-Click process but I am with on this one _ 1Click was dead before it ever got implemented.

  • Hey Guys,

    A few things.  One-click was recently released however, similar to any other shipped features, functionality comes in phases.  The feedback regarding NLA has been communicated to our product team and there is still work left to be done.

    Regarding .22 - We are currently testing the patch on VSA instances and scheduling a larger deployment to more servers over the next coming days.  When quality assurance is confirmed, it will be released into production.

  • When will .22 be released? .21 seems to be pulled back completely? It is no longer on the patch release page http://help.kaseya.com/webhelp/EN/RN/index.asp#40157.htm

    Edwin
  • Three and a half months since .20 release (3April2019) and two plus months since .21 was attempted.  No details or tentative release information on the .22 patch.  Two weeks since said that they were testing.  Hope this next release is stable....