Kaseya Community Patch Release - 11 May 2019

  • I believe the release to onPrem is currently "Controlled".  The team is confirming that some of the changes work across various environments before releasing it as GA.  This is to minimize the impact on those upgrading as well as to ensure we have immediate support for anyone who experiences an issue.

    Please be patient, as success continues, Engineering will be expanding the release.

  • Got the magic command from support. Found that .NET framework 4.7.2 is a pre-requisite - so those of you not yet seeing patch .21, make sure you have this installed and updated while you wait ;)

  • Thanks - that's good to know.

    Any comments from early installers for on premise users or experiences from the online workers?

  • Was hoping to install on a test machine (as there's no way I'm going to apply this to production at this point) - but still not available...

  • Thanks Craig - I totally forgot about the command line switches - installing on our test machine now.

  • I have .21 on my test system with no issues.  Installing on production tonight.  Has anyone installed it on their production server yet??? Issues?

  • There's nothing "broken" per se - some changed functionality that is not up to the same functionality that it used to be ... for instance, the way the network at a glance now works is totally useless to find out at a glance if a specific network/IP is online or not .... It used to be able to sort via group names, etc ... but now while it appears to do so - you now have to click on EVERY SINGLE IP to find the group instead of it being smart enough to show only that group name or view to see the specific machines....

    Along with a few other minor things, but nothing that will "BREAK" anyone seriously and prevent them from getting work done.

  • I've gotten confirmation from Kaseya about an issue with remote connect functionality in the patch. I don't have much details on it, but was advised to wait for the next patch. Hopefully coming out next week.

    From what I heard it seems issues with remote connect don't happen to everyone. Larger installations seem to be hit the most. We'll wait for the fix, before installing...

  • We have it on our production server and have not had any issues. (Knock on wood). We had to reboot our server after the install though.

  • We have switch our Production environment over last night.  Some nice additions including the system/user search.  Minor cosmetic issue with some add-on modules not having an icon associated and there is no way to lock the view with the names rather than just the icons.  The actual patch process went rather well save for the KNM service not starting up which popped up a prompt to 'Retry' which worked.

     - Would like to know what you heard in reference to Remote Connect in .21

  • The update is still unavailable for us. Any idea why?

  • I had to run kinstall with a custom switch that support had sent in order to get access to it before it was globally available.  They had told me on Monday that it would be GA by Wednesday...but it was (and still is) not available for GA.

  • got it, thanks!

  • Still not available for us in Sydney. Looks like .22 will be out soon enough anyway....

  • The unofficial word is that .21 will not be released due to performance issues. Whatever that means. We did fimd a bug around msmq that killed our csa servers performamce, but ut was fixed by disablimg msmq logging.

    An announcememt on .22 is due this week supposedly.