Kaseya Community

"this app can't run on your pc" after I unblock excel app

This question is not answered


I am doing a test on Application blocker on my pc.

I blocked the following apps:





I then unlock the apps above. 

word.exe and powerpnt.exe are working fine after I unblock it but for excel.exe and mspub.exe there is a message that will appear when I tried to open the app and it is "this app can't run on your  pc".

Before I block the apps , it was working fine.

May I know how I can fix the issue?

Thank you in advance for the help.

All Replies
  • We ran into that issue in the past and found the "remove" option to be flakey at times and does not always remove the app we blocked on all agents.   You can check the "KaseyaFW.ini" on those machines to see if those apps are still listed in that file.  If they are, they will still be blocked.

    As an alternative until the issue is someday fixed is we only add/remove apps on our test server agent using the GUI as normal and test, then created a script to deploy the "KaseyaFW.ini" file from that test server to all agents hourly. This method has worked out better for us....for now.

  • thanks :)